Not Sure How to Use Roon With New Internet Setup

I had a modem/router from Comcast that I used with an endpoint for Roon. Worked fine after some help from folks here. When I moved my internet setup changed and I use a usb wifi adapter to connect to a pay-as-you-go internet service.

What I would like to do is connect to Roon via ethernet on the same Windows 10 machine. I have a Dynex DX-E402 switch, Allo Digione, and a dream. I plugged it all in and Roon doesn’t see the switch in the networked area so clearly there is work to do. I don’t know much about computers but I can follow instructions very well. Could someone tell me what I need to do to get Roon going via ethernet again?

You have WIN10–>Dynex—>Digione—>DAC?

That should be good.

Don’t understand what you mean by this. Roon is never going to report on the switch or the Digione in the networked area, just the DAC.

Did you connect a DAC, if so did you enable it in Settings—>Audio—>Networked? Does your DAC need a WIN10 driver?

That’s what I meant. Doesn’t see Digione. When I enter dietpi.local into my browser I get this message:

This site can’t be reached

dietpi.local ’s server IP address could not be found.




If your complaint is that Settings—>Audio—>Networked does not show DigiOne, I am saying that that section will only show connected DACs’ drivers.

Again, have you connected DAC and/or does it need a WIN10 driver?

If you are trying to get into DietPi, so that you can choose how your DAC is connected, then I have never had success using xxxxx.local in a browser.

Best to use the IP address.

I don’t understand the question about drivers. I’ve got a a spdif dac attached to the Allo device. When I had the different setup it looked like this:

Aha, I think I am doing you disservice. I am use to using a USB connected DAC, maybe SPDIF doesn’t need a DAC connected to show in Roon?

Have you connected your DAC?

Dunno, let’s tag @support.

BTW - in your example for zone 2, ALSA is a driver.

Thanks for trying, Slim. Yeah there’s a dac. To be clearer, I’m connected to the internet via a usb wifi adapter, using a service where you pay as you go.

All I have done with the switch and digione is plug the switch into the ethernet port in the back of my computer and plug digione into switch.

SPFDIF does not return DAC information and the DigiOne does not have a USB interface. Endpoints like the DigiOne are what show in Roon not the downstream DAC.

1 Like


The first issue to fix is why your computer cannot access the DigiOne. Once that is corrected, then worry about Roon. It might correct itself.

My guess is that when the network was changed, the IP ranges were changed as well. I would get an IP sniffer like Fing to search your network and tell you what the connected devices IPs. I think it is a free download for Windows.

DigiOne’s are great if you want to use a Coax connection. I have one and its been rock steady feeding one of my DACs, I think I have it plugged up to a Schiit Modi Multibit. A lot of people use 'em with Yggy’s and forgo the USB.

Thank you. I will do as say.

The sound has been good through the little Allo device. A step up from coax straight out the box.

Yeah, I am strictly a USB guy.

At least, now I understand a little better how SPDIF connections show up in Roon.

Doesn’t help this OP, but for next time.

You’re probably right about the IP ranges.

I used one called Advanced IP Scanner. It shows three devices. One is my pc, another is an ip that has the same mac address as my pc with ip a digit off, and a third is a different ip with a manufacturer named “Benu Systems”. I don’t think Digione is any of these because I get the same results with or without the switch and DigiOne turned on.

So can you fully explain your network setup as I think this is the route of your problem. How do you get your internet from I am seeing you mention usb dongle is this for the internet? What’s this connected to exactly. You mention a switch what is feeding into this switch?

Hello @Matthew_Browne,

Thanks for contacting us regarding this issue. I see a few issues here:

  • You mention that you have the internet working only though your USB adapter that’s providing the pay-as-you-go service. This indicates that the rest of your network might be on a different subnet and that the USB adapter is using it’s own subnet to handle the internet connection.

  • All your networking devices are missing. This could indicate a possible firewall blocking Roon somewhere. I would double check to make sure that Roon and RAATServer are added as exceptions to your Windows Defender firewall for both public and private networks, you can use these instructions to check.

  • The ERR_NAME_NOT_RESOLVED might be expected if the local LAN is not working properly. Now that the Core is using the USB adapters it would be on it’s own subnet and it does not communicate properly across the two subnets because it’s trying to send a request to the dietpi on the USB adapter and the dietpi says it’s not there, this is because it’s reaching out to the internet while you’d want it to reach out to the local network.

I see a few possible solutions/useful tests here:

  • Can you check to see what happens if you remove the USB adapter from the Core and leave it just on Ethernet? Does your Allo Digione show up again when you remove it and are you able to play local tracks as expected?

Depending on this answer:

If no, then this could indicate a firewall issue somewhere along the chain. I would try the above Windows Defender exceptions I noted or temporarily disable any other Antivirus/Firewall applications.

If yes, everything shows up as expected again and you are able to play local content to your Digione, I would then take a look at bridging the two connections. You can give this a try in Network Sharing and Settings by clicking two network connections, such as the USB adapter and the LAN and then right-click and Bridge them together. This will create a new Network Bridge and should allow you to have internet access while still maintaining the Ethernet connection. You can read further on Network Bridging here.

My thinking here is that multicast is going wrong somewhere and that your Roon Core is trying to communicate via multicast on the USB adapter network while the devices are actually located on the Ethernet LAN subnet. Roon does not work as expected across multiple VLANs and that’s what you basically have set up here and it’s causing issues.

If that still does not work, I would then take a look to see if you can connect the USB adapter directly to the Dynex Router/Switch combo unit with something like this: USB to Ethernet Adapter and USB Gender Changer. I have not tested these myself but it might give you the bridge you need to connect it directly to the switch and then everything is back on one flat network.

Please let me know if my suggestions are helpful!


1 Like

I think the issue is your switch and connected devices have no DHCP service and your windows pc would also have to share the Usb internet connection to the lan port in order for roon to see the devices. In Mac OS it’s an option called internet sharing but on windows I’m afraid maybe google will be your best friend.

Most networks need a router to do the dhcp, but your windows pc could do this function. Some routers support usb internet dongles too that would perhaps be a better solution for the other devices to share via.

On your PC, set the Ethernet adapter IP to the old IP range, making sure that the new adapter isn’t using same range. I believe your old range is 10.0.0.x from your screenshot, due to not having any router, you won’t have DHCP running, meaning that the DigiOne won’t be able to communicate as it will be trying to find an IP. I don’t use a box like that so am not sure how to configure but you need to set it to an IP on the same subnet as the PC. Then they should communicate

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.