Notebook freezing with Roon core—my solution might help you

i wanted to post a solution I’ve discovered to a vexing problem with my Roon core constantly causing my Acer notebook to freeze after 30-90 minutes of playback activity, in the hopes that it might help someone else in a similar situation.
The notebook has an SSD drive, and I also have a 4TB Western Digital external drive attached. When streaming from Tidal or playing music from my library, the notebook screen would inevitably go black and the notebook would become unresponsive, even though the power light remained on and the backlit keyboard remained lit. The only solution was a power button reboot. No other programs were causing problems, and in normal use the notebook was fine. It was an issue with Roon only.
After months of frustration, and attempted fixes, I discovered the “Link power management” setting for SATA devices was set to on. This was found under “Intel rapid storage technology” in the notebook’s programs menu. I turned it off and rebooted the notebook.
I tested for 36 hours of straight playback. No freezes. I have subsequently used the notebook as a Roon core for a week without a freeze or crash.
It is my understanding, from research, that beginning with Windows update 1809 this setting was turned on by default. The timing of that update pretty much coincides with the beginning of my Roon problem.
If you’re experiencing anything similar to this, try turning “Link power management” off, if it exists on your computer. It certainly worked for me.
I hope this helps someone. For me, it was a long road. This as pretty much the only thing I had not tried, short of a total Windows reinstall.image|690x239


No image but I’m tagging @support just so they can be aware.

Network interfaces can also have power management settings, so always worth checking if you have an issue that occurs after a specific time of inactivity. Windows Event Viewer should log any activity like that so check first for clues.

That’s the first thing I did. I’m computer and network literate, so I tried all the usual fixes. Oddly, my problem didn’t occur after a repeatable specific time, but usually within a range of an hour or so. However, I wasn’t aware of the intel link power management for SATA until I discovered it recently. Nor was I aware that it’s default state seems to have changed to “on” from “off” a few months ago. It’s pretty obscure, and actually not particularly useful. Of course, there can be many reasons for problems, but since I suspect this may be the last place many Roon users look, I thought I’d make people aware that it can be a potential problem.

Hi @Toolio,

Thanks for the information, appreciate it! I have noted this in our internal documentation and we will keep this setting in mind if other users report similar symptoms.

1 Like

You’re quite welcome. For the sake of others, I hope it’s not a common issue. However, I’m glad to have the core back and running well on my notebook.

1 Like

Yes. LPM is often bad for SSD. Some performance guides tell people to disable it along with C states. It seems that energy saving is especially challenging for SSD firmware.

In the early days of SSD any energy saving was bad. In the worst case one would have to never power down or standby the PC or risked the (specific models and firmware of) SSD not appearing again on next boot, until a few generations of hardware advancements and firmware fixes later.

To a much less extent energy saving Ethernet also caused some obscure issues with some hardware.

Interesting. Thanks for the details. Also, from what I’ve read, the energy savings when it’s turned on, at least with an SSD drive, are minuscule. As we all know, SSDs don’t use much energy, anyway. What interests me, assuming what I’ve read is correct, is that Microsoft decided to make “on” the default setting in Windows 10 build 1809, which I believe was released around September 2018. It was one of their buggiest, and most criticized, updates that required quite a few subsequent fixes.

I don’t run Roon core on my Laptop but have noticing it freezing up and being very slow as reviving from sleep of late. Noticed this was on so turned it off. Hopefully it helps, thanks for the tip.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.