NUC and external drives

Core Machine (Operating system/System info/Roon build number)

NUC 7i7BNH / M2 SSD128 / 8Go RAM

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos and soon USB DAC+hifi out of the NUC

Description Of Issue

(sorry french is my native language)
I am new and I find everything a bit confusing. I am facing some different problems…

  The Rock is working fine with Qobuz streaming. It was working fine on my laptop and its music library. Now on the NUC I have dificulties to implement libraries.

1- I have an external Samsung SSD 1To fixed to an USB on the NUC. It is not detected and I cannot find anything in “storage” in the Rock. I imagine that it is because there is a Samsung APP wich is protecting the SSD with a password.

  • The Roon system cannot handle this?
  • If it cannot handle, anyone knows how to set the Samsung APP off (without deleting everything?)

2- I have an old ethernet WD “MYBOOKWORLD” hard drive connected to my internet gear (french Freebox router with fiber in). I can see and use it on the net with my laptop and PCs but Roon is not detecting it neither with \MYBOOKWORLD\public\musique nor with IP adress… Is it a problem of compatibility I won’t ever be able to solve?

Thank you very much for your help.

How are the drives formatted? Mac OSX journaled drives won’t be detected.

If you go to the ROCK GUI (above) is the drive listed under internal storage? If it isn’t you need to format it (exFAT) or do it through this GUI. Of course, that will erase the whole drive.

As for the other drive not being detected, it could be the same problem as well. But you say PC’s so it might be formatted correctly. Did you try turning off the firewall?
If it isn’t something easy like reformatting the drive it might be a network issue, but Support will be able to fix it. I’m just a user trying to help.

Welcome to the Roon Community Digipat.

Thank you.
I had seen that the Samsung is in FAT32 but it is not listed in the Rock GUI. Internal Music Storage does not appear.
I did not try with the firewall.
I am going to try to find how to put the samsung app out of the SSD…
I’ll be back soon.

What OS are you running on the NUC ? Sorry…just spotted you installed ROCK ? correct ?

Yes. I only installed Rock

Hi @Digipat,

Welcome to the Community! Let me try to address some of your points below:

Which “Storage” section are you referring to? There are two storage locations we should check here:

  1. From a Roon Remote (iPad of other PC) in Roon Settings -> Storage -> Add Folder and see if there is a drive appearing on the left-hand side

  2. From manually connecting to the ROCK share and checking if the drive shows up in the OSX Finder or Windows Explorer folder. You can connect to this share by opening Windows Explorer (Note: not internet explorer) on your PC and typing in \\rock into the address bar. There will be a Data Folder and then inside the Data folder there is also a Storage folder

If the drive does not show up in either location, then yes it is possible that this is due to the SSD password protection.

When you set up the shares in this way, you will generally have to provide Roon the storage location for the router itself. For example, on my TP-Link Router + USB drive, I had to go in to add it as the IP Address of the router and the share name displayed inside the router. E.g.\share1

This might show up differently with the router you have but if you have questions on how to set this up, it would be best to contact Freebox and ask them for the specifics. The wording that you can use ask them about this aspect is “Setting up an SMB share via the Router for USB connected drive”.

Hope this helps and do let us know how it goes!


Thank you very much Noris.
1- There is nothing in either storage folder…
2- I have tried \\MYBOOKWORLD and \\MYBOOKWORLD\public\Musique HD
No result…
And now another problem I am going to post on another post as it is different.

My problem 1 is solved…
The problem was the password system of Samsung.

I did not succeed to remove it as my Samsung Daemon SSD was not up to date… Without the password everything is ok with the hard drive on the NUK.

My second problem of WD disk on the router is not solved yet. I’ll tell you if anyone interested in.

Hi @Digipat,

Glad to hear that removing the SSD password resolved the issue!

As for your second issue, as I mentioned before you will need to specify the share name that the router uses, and this might not necessarily be \\MYBOOKWORLD. Your router settings should list the share name that it uses internally, on my end even though my flash drive is called “Music Drive”, I had to follow the naming convention that my router provided which was \\share1.

Again, this might be different for your router and since I have not previously used your specific router before, but if you want you can reach out to Freebox and see if they can provide you some documentation regarding the way it lists the USB share for the network access.

– Noris

Oh yes I understand. Sometimes things appear to be Logical but they follow other rules.
I’ll try tomorrow (French Riviera time :wink:) to “walk by” my router’s country and understand it’s logic.
Thank you again.
I’ll keep you advised.

1 Like

I am trying to understand my router but too many things “knew” to me…

I do not know how to find the path for Roon to find the MyBookWorld. Apparently the hard drive is known as a NAS under the name of MyBookWorld but I am not sure…

My guess, would be under Partages Windows?

GOOOOD it should be Freebox_Server but….
Not working

but I cannot even acces via internet explorer… I have to search my router setup again

Under username enter the username you use for that computer, and also enter the password for that computer.
Normally Workgroup is left empty.
I think that’s why you’re getting the can’t connect error.

Hi @Digipat,

Based on your screenshot, you may want to give these a try in Roon:

Emplacement du partage resau: \\Freebox_Server OR \\\Freebox_Server
Nom d’utilisateur: (leave empty)
Mont de passe: (leave empty)
Groupe de travail: WORKGROUP

If these settings do not work, I would clarify with the router manufacturer further.

– Noris

Thanks Scott G but even if my Core is not on this computer? I use a Nuk with rock

Boris, I tried both bit no result. I am going to investigate and I’ll be back to give the solution here… I hope

1 Like

Sorry Digipat. I didn’t recognize this was a network drive (NAS).
At least on my Synology NAS, when I click to add a network share I have to enter the username and password for the NAS. In my case I use my administrator username and password and leave the workgroup blank. Maybe there are some permissions you need to modify on your WD My Book World?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.