NUC drops Meridian 818 [Resolved - Up to date firmware]

Just built an i7 NUC and migrated one of my Roon Servers to it. It’s connected to an Express via ethernet, as is the NAS and my Meridian 818v2. I can connect, via USB to my headphone amp, and the remote connections seem to work fine (hours of listening to both). However, I’m having lots of trouble connecting to my 818. Sometimes Roon sees it, sometimes not. Sometimes I can physically power down the 818, and then Roon finds it on the network once powered back up. I’ve never been able to play even a whole song. The 818 disappears and Roon asks me to select an audio zone. Then it comes back and skips to the next song. Then it stops and the 818 is gone and Roon asks again for me to select an audio zone. Help.

I should say that the server I have been using, on a Mac Mini, can find the 818 no problem when connected the same way. I just tested that again, and am in fact using it while I figure this out. I cannot be without music.

Hi @Rick_Ayre ----- Thank you for the post and sharing your feedback with us. Both are very appreciated!

Moving forward, I would like to gather the following from you, to see if we can determine what is causing this behavior to occur:

  • In regard to your network topology, besides the Aiport Express, are there any other networking devices in the chain of communication?

  • You mentioned that the MacMini is having no issues finding the 818. How is this device communicating with your network? Is it also attached to the Express like the NUC?


Hey Eric, thanks for the prompt reply. The only things connected to the Express via ethernet are the NAS, the 818 and either the Mac Mini or the NUC (I turn one off when using the other). And, yes, the Mini is connected in exactly the same way.

Not sure what you mean by chain. The Express hosts a network with lots of WiFi devices. No ethernet connections other than what I use for the music.

I am not sure why you are doing this?

I am trying to migrate to the NUC. When it doesn’t work I still want to listen to music. So I turn off the NUC and use the Mini to serve Roon. When the NUC works with all my devices I will unplug the Mini and it will find a different job. But not until then. Is that so weird?

What network switch is your 818 connected to? I found that my D-Link had real trouble with UDP and my 818v3, but I’ve had no problems with the switch in my Billion router or an Apple Time Capsule.

It’s connected to the Apple Extreme.

Hi @Rick_Ayre ----- I appreciate the follow up! Thank you for providing the requested feedback.

Apologies for any confusion. When I mentioned the “chain of communication” in my last post, I was merely looking to understand how information is being passed along your network. For example, this would resemble something like:

Modem - > Ethernet Cable -> Router - > Ethernet cable - > switch … etc etc etc

The only information missing from my very stripped down example, would be the makes and models of all involved devices. Based on your follow up it sounds like there may be some confusion here on the devices being implemented. From the sound of it, it seems like you are using an Apple Airport Extreme (base Station?) and not an Apple Airport Express. Please confirm.


Exactly, sorry, my misspeak. It is an Extreme.

The network is LTE modem -> Ethernet -> Extreme -> WiFi -> Extreme -> ethernet -> NUC
-> ethernet -> NAS
-> ethernet -> 818

Does that answer your original question?

Hi @Rick_Ayre ---- Yes it does, thanks for the clarification. Very appreciated!

Moving forward, during your troubleshooting of this behavior have you tried (temporarily of course) testing with “Wifi” removed from the equation? I’d be curious to know how things behave without the Wifi “jump” between the two “extremes”.

Looking forward to your feedback!

WiFi is turned off, on both the Mini and the NUC. If I turn WiFi off at the Extreme I can’t share my Roon music to my remote computers, which I do now, and works fine. Is that what you wanted me to do?

Hi @Rick_Ayre — Apologies for any confusion, please allow me elaborate a bit.

What I was asking, is if you had tried testing with Wifi removed (completely) and making use of only hardwired connections between your various devices. If I were trying to test without the use of Wifi, I would try the following first:

The network is LTE modem -> Ethernet -> Extreme - > Ethernet (x3) - > NUC / NAS / 818.


Sorry, but I think that is exactly what I said I have. All three devices are ethernet to the Extreme. Exactly as you diagram. I guess my diagrams aren’t clear.

Do you know what version of sw the ID41 card in the 818 is running? You can find out by browsing to its IP address which will give you the ID41 configuration page. As you are not running Sooloos the ID41 software will not be updated automatically, there is a way around this. Using a windows pc download the Meridian Sooloos configuration program install it and then with the pc connected to the same network (wired or wireless) as the 818 run the program, if the 818 requires an update if will take place automatically.
There have been fixes for ID41 cards dropping off the network, even if this does not resolve the issue it is good practice to keep the 818/ID41 up to date.

Thanks Ratbert. I suppose I could borrow a Windows PC. While my house has over a dozen computers, including Chromebooks and various Linux boxes, most are Macs. No PCs. I still don’t understand though why I experience the 818 dropping ONLY while running the Roon Core on the NUC. NEVER while running Core on the i5 Mini.

Yeah, this a strange. We’ll do some testing on this and see if we can reproduce anything similar (I don’t believe Joel is running ROCK, but I could be wrong).

Anyway, @Ratbert’s suggestion is still a good one. Are you able to confirm the version number of the ID41 from the web interface?

Also, do you have any issues streaming from the NUC to other zones, like Roon Bridge running on one of your other devices for example? Just trying to eliminate variables here :slight_smile:

I’m sure we can figure this out @Rick_Ayre – thanks for your patience!

1 Like

I’ve not actually tested the AirPort Extreme as a network switch, but I’m 99% certain that the TimeCapsule is simply an Extreme + a hard drive, so I think that it should work.

When it comes to troubleshooting network connectivity, experience has taught me always to work up from the bottom of the OSI model. i.e. start at the physical layer.

  1. Check that the cables are properly seated.
  2. Check that the cables aren’t damaged.
  3. Check that you’re not accidentally using a Cat.5 cable with a Gigabit switch somewhere.
  4. Re-check 1-3 above.

It’s so tempting to think about the application layer, but it’s usually the wiring that is at fault. The number of times that this has solved my networking problems is unreal: misuse of a Cat.5 cable; a broken tang on an RJ45 connector which has slipped out slightly; etc.


I could not bring myself to use Windows, so I did the next best thing. I installed a Meridian 818v3 that is completely up to date. Funny thing, although after many years working with computers I am not surprised, the NUC works fine over ethernet to the newer Meridian. Of course, now that I have an 818v3 I will switch to USB. I suppose it could have been old firmware. It certainly seems to have been. Oh well. Live and learn.

You bought an 818v3 to avoid using Windows? :smiley:

1 Like

Pretty crazy, hunh?

1 Like