NuC endpoint and DragonFly Cobalt volume issues

Core Machine (Operating system/System info/Roon build number)

ROCk

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

N/A

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NuC 3815 with ROCK & DragonFly Cobalt

Description Of Issue
Volume going to 100%

If had this a number of times now and thought it now needs reporting . I have found that my NuC which is used as an endpoint only with a dragonfly Cobalt and headphones outputs volume at max

Tonight I just switched it on and started playing an album listening in headphones all was good, I hit volume up in the Roon app on my mobile and the volume seemed to output volume at max, nearly blew my head off downing volume put it back where it was prior and could not repeat the behaviour. I have had similar behaviour with the cobalt when it’s not been in use and I switch playback to the NuC and cobalt and its output straight away at 100%.

Not sure now this can be debugged but it’s happening often and is obviously very annoying , painful and makes me concerned it may damage my hearing and headphones.

Support please advise on how we can get to the bottom of this.

Hello @Simon_Arnold3,

Can you let me know the exact local time + date when this behavior next occurs? Also, just to confirm, the mobile Roon app was the only one controlling your Core at the time?

Yes only one controlling the end point. Will see if I can replicate the behaviour tonight.

1 Like

@noris 20:43 GMT Playing DJ Shadow Our Pathetic age, lowering volume triggered excessive volume. PM me to get account as it’s not linked to my forum account. My headphones do not appreciate this at all and I am sure it’s damaging them as bass is more distorted.

Hi @Simon_Arnold3,

I believe I already have your email address from one of our previous interactions, and I enabled diagnostics for your ROCK, but I am not seeing any playing attempts listed in these logs.

Perhaps you have multiple ROCK units on the same network and I received logs from the wrong one? Do you mind sending me manual logs from your ROCK (the Core one) by using these instructions?

Yes I have two rocks one is the core the other is the endpoint I am having issues with the Cobalt.

Uploaded logs to here
https://1drv.ms/u/s!AgHQUEVFVR_nztgOiWF49BkPusettA?e=CoycpY

Hi @Simon_Arnold3,

Thank you for sending those logs over, I have located the play attempt and have forwarded it to the technical team for review. Will let you know once I hear back.

Just to confirm - the Cobalt is the only zone connected to the NUC endpoint? Have you seen this behavior for any other DACs connected to the NUC?

I have only used the Cobalt with it so far.

1 Like

Hi @noris any updates on this please?

Hi @Simon_Arnold3,

Your case is still pending review by the hardware team. I just pinged them again and once I have further feedback I will be sure to let you know.

2 Likes

Hello @Simon_Arnold3,

We tried to reproduce this with a DragonFly cobalt connected to a NUC and were unsuccessful in doing so. We tried using the “volume up” and “volume down” buttons in Roon, they always acted as expected. Are there any different ways to get into this state? We’re continuing our testing, just looking for some guidance.

-John

It happens when the NuC is powered up and then music played via the Dragonfly and volume altered.

Did it again this morning. I move it up two volume clicks and it blast out, back down it goes to normal level. If you cant repeat this I wonder if my units faulty?

Not sure it’s important but I am using volume leveling set at 14db and volume limit. Volume limit I added in when it started to do this as a safety precaution.

Hello @Simon_Arnold3,

After some further finessing, we were able to reproduce the behavior you are describing with the volume jump. I’ve passed the technical feedback to the development team, they’re going to take a look at this and determine if this issue is triggered by Roon misbehaving or a bug in the volume implementation on the device.

-John

1 Like

John is this a different issue or the same issue as the one for Android 10?

It might be related as I am using an Android remote, although it does the same using Windows remote to.

If you’re seeing this on Windows as well, then it is different from Volume going to max using Samsung Galaxy Tab S5E

1 Like

@john has anything been done about this issue. I am also having issues with this via Roon bridge on a raspberry pi. On boot it’s always setting the volume to 100% and not remembering what it was previously set as. This happen in Ropieee and also on VitOS which is a new distro by Silent Angel I just tried.

@support, @john is there any update as to this issue as it’s prevalent on all Linux based distros I use. It’s becoming extremely annoying and not doing my headphones any favours.

Hello @Simon_Arnold3,

Thanks for your patience on this one. It’s a serious matter when we’re discussing the potential for damaging headphones or worse someones hearing, so we needed to ensure that we’re getting things crisp and correct.

We’ve performed some extensive testing across multiple linux distros and determined that Roon is not at all involved in the volume behavior you are experiencing. However, due to the severity of the issue, we’re going to reach out to the Audioquest technical team and work with them to get this resolved. We’ll keep you updated on the progress.

-John

2 Likes