NUC i7 ROCK Rebooting

Ever since 1.4 (or that is what I think) my NUC7i7BNH ROCK reboots every minute or so. Configuration is M.2 Samsung 960 EVO Series - 250GB. 16GB RAM. Ethernet. SBooster 19V power supply. I have tried re-loading ROCK, deleting and setting up library, audio devices, and almost every thing I can think of including setting BIOS back to defaults. Only thing I haven’t tried is re-installing BIOS.

Any ideas?? Thanks for your help!

Is the CPU fan ok, it could be it is overtemping.

I think so but will check. Thanks for the suggestion. Very frustrating. I have another NUC that is running Win 10 and it performs flawlessly.

I have the same NUC running Rock and have no issues.

This one was perfect until about two weeks ago. The CPU fan is running but internals were quite warm. I added an external fan blowing into the case just to make sure. While in there I re-seated the SSD and RAM. The hold-down screw for the SSD was not completely tight, so maybe that was the problem. Hope so. Gotta have my Roon!

Very much doubt the OS is the issue, it’s either running hot or there’s a hardware issue.

Agree that it is not the OS. It just re-booted again after re-seating the SSD and RAM and adding the external fan. I have tried it on several network connections around the house and the same thing happens. Guess it is hardware related on the NUC. Oh, well guess it is time to move back to the older NUC that is set up on Win 10.

Try another (original?) power supply. I have a little suspicion that your setup has approached the 36W limit of your power supply.

Your i7 NUC has 28W TDP, and actual worst-case power consumption can be higher. 960 EVO takes 5.3 W.

If you check out this Sbooster website, you’ll see it includes NUC7i5BNH but not NUC7i7BNH:

I don’t think this will solve your problem, but you can also try disabling Turbo Boost.

Thanks, Peter. I turned Turbo Boost off and also changed performance to Balanced. Hopefully this will help. Hope it is not the SBooster power limit because it did make an improvement in sound quality, at least to me… That thing is big enough that you would think it would power the NUC with no problem. BTW, I do not have an internal hard drive, only the M.2 so that helps with the power a bit.

Well, it re-boots even with the stock power supply, so the SBooster must not be the problem. So, must be something else on that NUC giving problems. Switched back to the older NUC with Win 10 with the SBooster PS until I have time to work on the ROCK NUC more. Thanks to all for the suggestions.

If you would like to diagnose this further, I recommend taking one of the two RAM modules out - in case one of them is faulty. If it still reboots, swap the RAM.

1 Like

I swapped the RAM and the M.2 SSD and it still reboots, even with the stock power supply. It won’t play more than about 10 mins without a reboot. So. something must be bad on the motherboard. My other NUC which is another i7 and runs Win 10 runs Roon perfectly so nothing else on the system is causing problems. I have an i5 NUC on order that is on the Booster “blessed” list. So, that should solve the problem. Thanks to all for the troubleshooting tips.

1 Like

I am not familiar with NUC hardware, but some computers have hardware test routines that can be triggered from the BIOS screen. Alternatively you can boot off a memory stick containing diagnostic software. Memtest is one that springs to mind but I recall there are Linux based images that will run a full set of hardware tests.

It appears that I may have been mistaken about what was going on with the NUC. Instead of re-booting, I now believe that my Synology NAS (1812+) was momentarily dropping connection. As fast as the NUC reboots with the SSD I could not tell the difference between a network drop/reconnection and a reboot. I suppose if I had watched the lights on the NUC that would have given me a clue. Anyway, I swapped the music file location to a different NAS (QNAP 4 bay) and the NUC is playing perfectly.

What I don’t understand is why my NUC that is running Win 10 never dropped the connection. Perhaps Windows is more forgiving of a momentary net drop than ROCK.

I reviewed the hard drive health on the Synology; one drive had one bad sector, one drive had 121 disc reconnections and another drive had >400 reconnections. Synology says that reconnections are not necessarily a symptom of impending drive failure, but it has to be a contribution. Maybe the disc reconnections were causing the momentary network drop…