NUC problems - needs reboot

I’m having a similar issue with my NUC8i3. When I first set it up about 6 months ago the NUC ran 24x7 without any issues. It was after one of the Roon updates a couple of months ago that it started to misbehave. The NUC server thinks its streaming audio to it’s USB connect DAC, or through the HDMI to my AVR. But, there’s no audio. I have to reboot the NUC to get it to work again. Then it works fine for a day or 2. If I could get it to reboot itself every night, it would be a viable workaround. My NUC has the latest BIOS and I looked for any type of scheduled reboot option in it, but it doesn’t have this feature.

One thing I noticed is that when the Roon server software is failing to stream audio to physically attached devices like the DAC or AVR, it is still able to stream to remote devices. I have a couple of Raspberry Pi’s running Ropieee and they seem to be unaffected and continue to function. I’m not 100% sure yet, but it seems (for me anyway) to just be an issue with directly attached devices. So, as another potential workaround I setup a RPi with Ropiee and have it feeding the same DAC via USB, rather than the NUC itself. It’s only been a few days, but so far so good.

Hello @Thomas_Prossima1, I’ve moved your post to a separate topic in the #support thread.

To help the support people can you please provide a brief description of your current setup using this link as a guide.

Thanks for the details here, @Thomas_Prossima1.

Can you provide some details on your network setup?

Does this issue happen with local content, streaming content, or both?

Thanks for your offer to help.
I had previously posted here a couple of months ago about this issue (even uploaded log files) but there was no resolution.

The ROCK is running on an Intel NUC8i3BEH with 8GB RAM and a 250GB nVME. The library is on Windows 7 PC shared folder (700 albums). 99% of my listening with these local files and I rarely do streaming.

I’m pretty sure now that the issue I’m having is only with directly attached devices. 6 days ago I switched from having the DAC directly attached to the ROCK (USB) to being fed USB from a RPi running RoPieee. So far it’s operating perfectly, as are the other 2 RoPieee devices I have setup on Roon.
It’s like the ROCK software forgets about the local ports. I don’t keep the DAC powered on all the time. When I do turn it on, the ROCK sees the DAC, but fails to correctly stream. I’ll see the timeline progress, but there’s no audio. Rebooting the DAC or pulling and reconnecting the USB cable does nothing. I have to reboot the NUC.

My next step was going to be to reinstall the ROCK software. I have a question for you regarding what’s the best way to go about this. I think there’s 2 ways to do this:

  1. Do a clean reinstall and then when complete perform a restore from my latest backup.

  2. Do a reinstall - but I believe there’s an option during the installation to recover from a previous installation.

Will either or both result in me recovering all of my previous settings, options etc? Which method do you recommend?

Hi @Thomas_Prossima1,

You could try an OS reinstall via the Web UI. This should preserve your database, but I would make a Backup of your database just-in-case.

An further option would be trying to set the current ROCK database aside and start with a fresh one:

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Use the fresh database for a few days to verify if the same issue occurs
  • Restore your database from a backup after checking behavior on the fresh database

I wasn’t clear on that OS reinstall option on the webpage, so I was hesitant to use it.
But, I tried it and it reinstalled in just a few minutes. I’ve also reconnected the DAC to the NUC running ROCK. Now I just have to wait and see if the issue returns.


After 8 days the NUC is still working just fine. I’m pretty sure reinstalling the OS via the webpage has resolved the issue.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.