Nuc Rock keep disconnecting with the Synology NAS music library folder

I would like some help please!
Here is my setting:
Nuci7 with Roon ROCK Ethernet to
ASUS router Ethernet to
Synology 918+ NAS (Music folder)

I have been adding the music folder to Rock music library with no problem at the beginning. But then I noticed that the music folder will be disconnected if I use a VPN on my router.
Then I found a solution of setting the router to individual device with VPN or without VPN, so I set both the Rock and NAS with no VPN filter. However it still disconnected time by time and cannot even reconnected for a while until someday it’s suddenly working again. All folder file, location, username and password hasn’t been changed at all.

My question now is, if that’s how it is for using a VPN and can’t be fixed. Can I connect the Rock directly to the NAS with USB cable or is there any other way I can connect them by wire without passing through the router or network?
How to adjust the setting in both Rock and NAS to do so?

Much appreciated if anyone can help!!

Well, I removed the NAS from the whole equation. Roon really likes the files to be local. I got an external USB drive that held all my music files, Copied them to the usb drive with a computer. Attached the usb drive to the ROCK.

Now, my music files are local to the ROCK and the NAS is used only as a backup copy for my music.


This sounds like a ip routing problem. The routing table in the Asus router will need to change when the VPN is started. default route ( should now point to the VPN, but your local network, LAN, needs a static route back via the physical port (ip address) it is connected to.

1 Like

Thanks for the advice!
I am just thinking if a USB drive can be set as local drive. There should be a way to use USB connection with the NAS too.

Thanks for the advice!
Unfortunately this is beyond my knowledge.
I have no idea how to set the up the IP address and direction between the router and NAS.

Is there a Routing tab in the web admin for your Asus?

Something like this?


Amazing! It’s working after the setting now!
I hope it won’t disconnect again.
Thank you so much for your help!!!

1 Like

That’s good. Glad to help :slight_smile:

1 Like