NUC/ROCK Roon core not connecting...Ethernet port issue?

Core Machine (Operating system/System info/Roon build number)
128GB NVMe Pcle Gen3 x4 MTE110S M.2
Crucial CT8G4SFS824A 8 GB Memory

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
BT Smart Hub 2 Wired Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Various RPI based players running Ropieee etc.

Description Of Issue
NUC/Rock core install in February this year and has run without fault until a couple of days ago. Network map shows Rock as being not connected.

I swapped Ethernet cables with equipment shown to be working. NUC cable worked fine in other equipment from same router port. No luck with different cable in NUC or with different router ports.

Ethernet port on NUC displays one green LED light on right (even when no cable connected) but no data flow LED on left.

I’m suspecting a defunct NUC Ethernet port or broken driver

I should be most grateful for any suggestions about how to troubleshoot this problem.

Please note, I’m not at all tech savvy but can follow instructions as demonstrated by the building of the NUC/ROCK and Rpi (and LMS prior to Roon)

PS. I’m currently streaming Music via LMS/iPeng using the same cable and port used for the NUC.

If you suspect a broken Ethernet port, you can confirm that it’s nothing else by connecting with a USB Ethernet dongle. Just as a test or permanently if that’s the easiest solution.

1 Like

Thanks. I never knew such things existed! Would it be just plug and play or do I need to alter NUC/Roon settings?

Should be PnP. It’s cheap enough to try out.

1 Like

Note that it will get an IP address via DHCP, so won’t be or is unlikely to be the same as the one the Rock had before. Your router should show the IP allocated or you can use a phone app like Fing to find it to verify allocation.

This in itself should not be an issue, but if your Control can’t find the Core, you will have to verify whether ROCK is connected to your network.

Helpful advice, thank you, I’ll keep that in mind.

Hi @MrBob,

Testing with a USB -> Ethernet adapter is an easy and inexpensive test to determine if the NUC is getting an IP address. You could also try connecting the HDMI output of the NUC to a monitor or TV, it should present you diagnostics info similar to below:

With this info, you can determine if the NUC is getting a valid IP or not.

Very helpful info, thank you. I’m expecting the adapter to arrive in a day or two. I’ll report back with what happens.

1 Like

Ethernet adapter arrived and fitted. Alas, success at first for a few minutes but then it kept dropping the connection. All other internet attached devices on my network are working fine. My NUC is definitely playing up. I did consider starting from scratch…updating bios etc, but I’m not sure how I’d do that without an ethernet connection. Any thoughts on next steps?

Open it up and reseat the RAM and SSD?

Ha…Certainly worth a try! I’ve just read a guide on how to update bios From a usb stick so I’ll take your physical steps first.

Hi @MrBob,

What does the HDMI diagnostics screen shot with the adapter in place? Does it keep switching between multiple IPs there? What about on the Web UI, is there anything of note on that page? You may want to check these two areas before going the full reinstall route.

Hi, the HDMI screen is the same as the one you posted, bar the build number and address. The Roon page you mentioned looks normal. The ip address remains constant but drops out. That said, I changed the usb adapter to the USB port on the front and it’s been stable for the last two hours. Fingers crossed it’s settled down a bit. Thanks again

1 Like

Are the ports the same USB type? One might be a USB 2.0 and the other a 3.0.

Good point! Just checked…3 rear, 2 front - all are USB3.

Hmm, The USB 2.0 are only available through internal headers. Interesting!

A few days on and the use of the usb ethenet adapter has been hit and miss with frequent loss of connection requiring reboots. I updated the bios and device settings but still no luck. The ethernet port is certainly defective. Amazon, bless them, are sending me a replacement NUC and collecting the one I’ve had since February. Ill back up the Roon database to the external drive. I’ll then remove the memory and storage cards…will I have to reformat the storage card when I load it into the new NUC and reload the ROCK OS?

1 Like

Hi @MrBob,

Do let us know how the replacement NUC works out! You’ll need to reinstall the OS and for the internal storage contents, I would also have a backup of the media before making the swap. Do let us know how it goes!

The replacement NUC arrived and is now set up and playing nicely. Thank you all for your help and suggestions.

1 Like

That’s wonderful news @MrBob, thanks for the update and glad to hear that the new NUC is working properly!