NUC - Switching on twice required

I use a NUC intel i7 and everything runs great since the beginning. But one little thing has bothered me since the beginning: I always have to turn on the NUC twice before the Roon Core is recognized. This is extremely annoying. My configuration:
NUC → pi4 roopie → USB DAC
(the NUC is connected to a switch where the pi4 is also connected to).
Any idea? Thanks!

Are you using a short press, i.e., click and release, or long, i.e., click and hold?

Have you tried powering off and restarting ROCK using the web interface: http://rock.local?

Short click … Shall i press longer?
Note: normally NUC is powered off as i use it mostly on weekends.

No. But i will try this on coming weekend.
Thank you!

You want to use the short press; the long press is a hard reset.

I find it most conveniant to power on via WoL.
I’ve got one app in Windows and one in my phone (Android).
Starting both my NUC Core and NUC Endpoint this way.
Also shut them down through the direct web link, just klick on that and it goes down.

I will try all of it. Thanks a lot!

Mine is turned on amd off daily , often twice . The quick short press does it . As mentioned the long press 2+ sec is a get out of trouble reset

Does the power light come on when first pressed? I had a NUC11i7 that was hard to power on. If you didn’t press the power button hard enough or squarely on it it wouldn’t respond but it was obvious when this happened since the blue light didn’t come on. I ended up returning it and the replacement had no such issue.

Yes, blue light is on when i short press the button.
Weekend i will try the WOL.
Thanks!

Any output on the monitor when this happens?

@glc650: there is no monitor.

Tried every advice. No change; need to switch twice.
Will live with this; there are more relevant problems out there…
Thanks!