NUC with ROCK will not update

Roon Core Machine NUC 10i7FHG

Rock Optimized Core

My NUC with ROCK will not update. Continues to run V1.8 build 1026. I cannot update it to V2.0 or to Legacy V1.8 build 1126. I have followed the instructions carefully. The NUC reboots remotely but each time I check the version it is V1.8 build 1026 so obviously nothing works. I updated my remote to Legacy but it won’t connect to the core.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I reinstalled the Rock Optimized Core Kit and my NUC automatically updated to Roon 2.0 and all is working well.

Support, you should add this to your FAQs. My NUC would not update or install 1.8 legacy so I reinstalled the Optimized Core Kit and it worked. I’m so happy to be back to listening!

1 Like

I’m glad you’re back to enjoying the music.

Best wishes,

I had this problem with the recent 2.0 update. All I had to do was to restart the Roon Server Software on the NUC and everything worked fine with the update after that. No need to reboot or reinstall anything.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.