NUC10i7FNH with panic after installing extra SSD

I just finished installing ROCK on my NUC10i7FNH with a Intenso M.2 128GB SSD and a Micron 256GB (MTFDDAK256MBF) .

First it didn’t work to install it with both drives installed. I could install it either on the M.2 128GB with the removed 256GB SSD or install it on the SSD with the Intenso as boot device disabled in Bios.

Now ROCK is on both drives installed and I am not sure if this is the problem. BUT I disabled the Micron 256SSD in Bios as boot device and it panics.
I then only got the Intenso 128GB M.2 as boot device, removed the 256GB SSD. Roon is running, on the tablet it installed the newest build and I could install the Codec too.
Now I installed again the 256GB SSD, made sure in Bios it’s not as boot drive and now I get again the panic messages. Why?!
Do I have now to format the SSD somehow separately?
Any ideas, hints?

It looks like the boot process can’t find the OS. I suggest you remove the SSD, reseat the M.2 and try again. If it still fails, reinstall ROCK with only the M.2 installed. Once this is working, add the SDD and you should see an option on the web interface to format the internal storage.

This I did a few times. When I remove the SSD then ROCK starts just fine!
As soon as I reconnect the SSD it fails with panic.
And yes, in BIOS the SSD is NOT set as boot device. Still it somehow tries to boot from it as if the SSD has priority over the M.2

BIOS is latest version from Intel.

I would try and format the SSD on a different computer and see if that makes a difference.

1 Like

I solved the problem.
Did install my SSD on my PC. It had 3 partitions. I removed them all, formated exFAT and reinstalled it on the NUC, did nothing on the BIOS and it worked right away.
So it seems that ROCK somehow detected the other ROCK installation on the SSD and panicked.
Not sure why as the M.2 was the only boot HDD, but anyhow, seems to be the reason.


Glad you got it fixed, “Kernel panic” is my favourite Linux error message…

switch_root: can't execute '/sbin/init': No such file or directory

This is the clue and the reason for the kernel panic. The boot process was unable to find the installed OS files.

And that could be a small bug of Rock. On both HDD was Rock installed and working.
But when both connected, although I just had one defined as boot drive it would give this panic.
Now I just formated the SSD and it works. Changed bothing on the M.2.

I doubt it. The boot process failed, i.e., ROCK was not running. The kernel loaded, but it was unable to mount the root file system. That’s why it could not execute the /sbin/init program, which is always the first program to be executed on Linux. Most likely a borked install; note that the MBR is written on the first bootable drive, so if you overwrite this for the SSD and then disable it, the boot process will fail. Thus, both installs would be broken.

Anyway, I’m pleased you’re up and running now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.