NUC7i3DNHE as Roon-Server doesn`t support DAC via USB

Core Machine (Operating system/System info/Roon build number)

Roon-Server: NUC7i3DNHE, Win10 Pro 20H2, Roon 1.7 Build 710

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Musical Fidelity M6si with DAC build in connected via USB to Roon-Server (NUC7i3DNHE)

Description Of Issue

I played around with Roon now for several weeks, used different installations of Roon-Server (old PC and Notebooks, always with Win10), several Remote Devices with Android and Win10. For audio I always used amplifier with DAC build in (MF M6si) connected via USB to Roon-Server.
It is a great SW, I really like it and decided to continue with Roon.
To come now to a final HW solution for the living room, I bought a NUC7i3DNHE to run the Roon-Server and connected the DAC of the M6si again direct to the USB.

Everything works fine, beside my main application, listen to music via Roon-Server, USB and M6si.

Roon Audio shows for the core:

  • System Output (not activated) there is no analogue output on that NUC
  • WASAI (no mame)
    That doesn´t change when I connect or disconnect the DAC.

If I connect the DAC to the Remote Notebook, Roon Audio shows

  • System Output
  • Realtek High Definition Audio
  • M6si integrated 24/96 WASAPI No Name

Everything works and music can be played on different outputs (System, M6si) of the remotes.

I would expect the same device (M6si integrated 24/96 WASAPI No Name) for my Roon Server (Core).

In Win10 Device Manager, M6si integrated 24/96 is shown.
The NUC has only USB 3,0, but it works on the notebook with USB 3.0 as well.
Do I need special drivers? Musical Fidelity doesn´t deliver a special USB driver for USB and it works when connected to the notebook.
Anything els I can do to get it running?

Thanks for your help

hello @Udo_Birke ,

Can you please share a screenshot of what you see on your server? have you tried assigning a name to the zone yet, does that help?

Hi noris,
thanks for your answer. Assigning a name didn´t help. I investigated further and it seems as if using Windows RemoteDesktop for my headless Roon Server causes the problem. After I did it with monitor and keyboard connected direct to the NUC, my DAC via USB was identified and could be enabled as I expected it.
Although I don´t know why it is not possible via RemoteDesktop I would consider it as solved.

1 Like

Hi @Udo_Birke ,

Thanks for the update, this is a known issue, please see here for more info:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.