NUC8i3BEH - Will get support in the future?

Yes, thank you, I do know that I don’t need ROCK to run Roon, but for my circumstances it is the best and the right way to run Roon for my environment, It will cost me another £120 to buy a Windows 10 licence, plus the need for mouse, keyboard, screen and constant updating is something I don’t want. I don’t want a bloated, vulnerable general purpose OS for Roon when there is a purpose designed OS available built specifically for the job.

The whole purpose of ROCK is to run Roon on a NUC, and a NUC is for me the most cost effective way to run Roon, I want it on 24/7, as a headless and generally fit and forget appliance that sips electricity and has all the power and capacity I will ever likely need for the role.

Well yes for me there was a pressing need to buy a NUC, I don’t have anything else available, so would have to build (all my and my families PCs over the past 20 years have been homebuilt to high specs and overclocked - except for laptops). So I went for what should be the preferred and most cost effective solution in my circumstances.

Well I should not have to be agonising over whether is is supported - when I bought it it was supported; I am naffed off at the fact that a machine on the supported list can simply be removed and it’s owners told Roon do not now officially support it. Had the message been “there is a problem, we are looking into it, we will do our best to support customers with existing NUC8s but we recommend new purchasers hold off or buy NUC7s for the time being”, I would be quite happy.

Well yes I would agree, but it seems it is not so very clear as my NUC8i7XXX was on the list 3-4 weeks ago.

So if supported NUC hardware goal posts can be moved or removed, it does nothing to a newcomer like me who has tried to do the right thing, to engender trust or confidence in the Roon setup.

I will keep my fingers crossed!


1 Like

Other than one case of not being able to use legacy boot (instead of UEFI) for ROCK, I do not recall reading other issues here.

Interesting, as I did use Legacy boot as the guide said I should, there was no problem switching from UEFI…

I have used a NUC8i3 for some weeks now running ROCK and it works well. It was no problem changing to legacy boot. However, it was a bit tricky to change the boot order. My M.2 didn’t show up for some reason and I was not able to prioritice USB boot. Somehow it worked anyway and the NUC booted from the ROCK USB-drive. I don’t think there is a need for changing anything in BIOS, except for the legacy boot. As mentioned before, Wifi won’t work because the lack of drivers in RoonOS.

I would disagree that we’re not “stepping up” – the message on the KB site says:

We have identified some issues with NUC8 compatibility and are currently investigating them. We are withdrawing official support for the NUC8 until these issues are resolved.

For the record, this is pretty much exactly the message – apologies if our communications didn’t convey that clearly enough.

As you can see in this thread, there are lots of people using these devices without issue. We also have some reports that require investigation, namely that some people are seeing devices that *only* support UEFI boot. The investigation is currently underway, and we are hoping to restore official support soon.

Obviously, we would prefer not to have to temporarily withdraw support for these devices, but what you’re seeing right now is us stepping up, and being transparent out of an abundance of caution – we suspect in most cases these devices should work, but we want to be sure. And if you’re having an issue, we’d like to know.

When we’re sure, these devices will again be officially supported, and we’ll update the knowledge base. We appreciate everyone’s patience while we look into this.


Just wondered if the people that are struggling to disable UEFI boot on an NUC8 are using just a keyboard? I remember when I configured my NUC8 a couple of weeks ago there was one step in the ROCK installation procedure that it wasn’t possible to achieve with just the keyboard (at least not a means of navigating I could find); however plugging in a USB mouse allowed the correct setting to be selected. I couldn’t be sure that it was the UEFI boot setting, but that might explain why some people have been able to configure NUC8 ok and others haven’t?

Thank you for the responses! Was just wondering if WiFi support will also be incorporated with this version in the future.

@mike Thank you for the clarification, being English I interpret the line “We are withdrawing official support for the NUC8 until these issues are resolved” literally (I did note that the issues were under investigation), rather than in the flavour of my version of what the message should have been, which you have stated is actually exactly what your message is meant to be.

Funny thing, language!

I will rest assured…


Because sometimes Win 10 is more convenient, and in my case without hicups or other disruptions I had with Rock. With Windows 10 no problems at all.

1 Like

I did have the same USB issue with boot sequence on 8i5, but the unit ended up booting on the Roon image on USB.

However, I did never the external storage to work on USB. I still think this is more a NUC issue than a ROCK.

But in daily use the ROCK works perfect on the Intel NUC 8i5.

Just as a reminder : for those of you not willing to go Windows with a NUC, it’s possible to install a Linux Server such as Ubuntu on a NUC8i3, then Roon. Not as straightforward as ROCK to install but works headless like a charm afterwards. Another advantage is to allow the installation of HQPlayer or Roon Extensions on the same machine, which is impossible with ROCK.

@alec_eiffel As someone who knows less than nothing about Ubuntu, unless there is a step by step guide (as with ROCK Roon documentation which led me through the process step by step) this seems too difficult. I understand Windows and networking, (and if you want a secure Active Directory designed and built - I’m your man, but UNIX is another world) but do not want to run Windows 10 on my Roon NUC, and I want to run Roon on the NUC and listen to music, not take the pain to learn a new OS.

I have had a look, but cannot find anything that gives me the confidence to give it a go. I am sure there are many like me, and for us the ROCK concept is perfect…

I have not seen any detailed step by step guide but it’s not much more complicated than ROCK.
First intall Ubuntu Server 18.04 LTS - lots of tutorials on the web.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install ffmpeg
sudo apt-get install curl
sudo apt-get install cifs-utils
curl -O
chmod +x
sudo ./

That’s it


Thank you very much!

ROCK is working for me on a NUC8i3BEH flawlessly. I installed it something like three weeks ago. Getting the database to recognise music that I migrated to internal storage was a bit tricky, but I found the solution in some old post here in the forums.

I have a M.2 SSD, internal 2.5" SSD, 8 Gb RAM. I connect via wired ethernet.

And just to add the growing list; my NUC8i3BEK2 has been running ROCK, without incident,
since the 4th Feb.

As the OP wanted to chime in and agree with the above posts—just set up ROCK on my NUC8i3. Very straightforward, working smoothly so far.

1 Like

It is now supported, with some caveats:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.