NUC8i7BEH Not ready indicator on Roon Database & Settings

Reporting back in after doing the upgrade from NUC7i7BNH to NUC8i7BEH. The whole process went as smooth as possible.

  • Prepare thumb drive with NUC8 bios update file
  • Disassemble old NUC (m2 SSD + RAM)
  • Assemble new NUC, insert thumb drive
  • Connect keyboard and monitor
  • Boot up new NUC, hold F7 to go straight to BIOS upgrade
  • Upgrade BIOS, reboot, hold F2 to go into BIOS
  • Make settings as advised by Roon
  • Custom settings (disabled WiFi, BT & Thunderbolt, put fan control in “Silent” mode)
  • Connect Ethernet
  • Reboot into ROCK, check if everything works (needed to unauthorize old ROCK from Roon Remote)
  • Shut down NUC, disconnect keyboard and display, shove it into the cabinet :wink:
  • Send old NUC back to Amazon :yum:

Even without custom fan control profiling, this NUC8i7 seems to be a lot more quiet than the NUC7i7. Very happy with the upgrade.

Well I seem to have spoken too soon… Since New Year‘s Eve something in my ROCK seems to go wrong, forcing me to restart the server via the web interface, on which I can see a „Not ready” indicator on the “Roon Database & Settings”. I’ve tried a new DB and various reinstalls—unfortunately this happens seemingly randomly after a while.

@support is it possible to have a look into this? I’m sure you’ll want to eventually offer full support for the NUC8 series and rule out any issues…?

Edit: I’ve also removed any custom BIOS settings I had set before and did a full reinstall with USB stick. Similar issues.


See if these are related to your issue or not:

Try using a spare SSD or HDD instead of the current m2 SSD for the ROCK boot drive, as an experiment only.

If the above does not help, run this for 24 hours:

Did you figure this out @saschamt?

Thanks for asking, but no. The only thing I’ve figured out is that ROCK won’t run on the NUC8 for me. I’m currently running again on my NUC7i7 without any issues (uptime 4.5d). Things I’ve tried before:

  • New RAM
  • New SSD
  • Fresh ROCK install
  • External SSD connected via USB
  • BIOS Re-Flash

Even with the new SSD and the external USB SSD, ROCK will show the previous alert (“Not ready”) and become unresponsive. As my return window closes, I will send back the NUC8 and extra RAM+SSD today. I’m fine with the NUC7 as it is solid “like a rock” :wink:

2 posts were split to a new topic: NUC7 vs NUC8 for Roon