Nucleus and Multichannel ouput via HDMI issue

Hello @regeli,

We apologize for the lack of communication on our end. These kinds of issues are often the hardest to pin down as they involve unique files, hardware, and QA testing spanning multiple internal teams at Roon. This isn’t to excuse our performance here, but I wanted to let you know that this issue is still under investigation.

We have not received other reports of broken multichannel playback on Nucleus or Roon in the same manner that you describe, so I’m hesitant to point the finger at a hardware limitation that affects all Nucleus units.

I’ve bumped the priority on this ticket and hope to get back to you shortly with some next steps.


With a circa 2018 Microsoft Surface tablet (fanless i5 without heroic cooling), I had problems with dropouts, particularly at the beginning of a song, when trying to down sample 5.1 DSD64 to 5.1 176.4/24 PCM. I also had channel mapping issues: even though it’s a 5.1 system, the surround channels were getting sent to (nominally) the rear channels of a 7.1 layout. The channel mapping was easy enough to overcome. I had to experiment with multiple mini-DisplayPort to HDMI adapters, and upgrade the Intel HDMI audio driver (Windows) to make things sort of work.

However, when it worked, it sounded just fine. I eventually gave in and acquired an exaSound multichannel DAC that plays DSD just fine, and has been very stable, as it should be for the price.

Good luck!

exaSounds are a great choice if you want multi-channel playback.

1 Like

Just to follow up on the exasound recommendations – to the best of my knowledge, exasound DACs will not by themselves play multichannel from NUC/Nucleus via USB, as exasound does not provide drivers for linux (only for Win and Mac). They will need a multichannel-capable Roon-ready streamer as an intermediary (or built in, as in the latest model, which is the e88, I think).

Disclaimer: I’ve looked into exasound but never used one, so actual exasound owners, please correct me if I’m wrong about this!

Hello @otinkyad,

Exasound DACs will not function with other Linux computers/streamers/servers besides for Exasound streamers.


You are correct except you mean s88.

Hello @john – Right, good clarification, thanks. Not only does an exasound DAC need a streamer (to work with NUC/Nucleus/linux), but it needs specifically an exasound Roon-ready streamer – thanks for confirming and clarifying –

Ah, thanks for that clarification!

As an exaSound owner, I’ll note that you could use a Mac or Windows PC running RoonBridge (or NAA if you use HQ Player, etc) as your “streamer” because exaSound provides drivers for those operating systems. However, the primary thrust here is correct: a non-exaSound dedicated streamer basically won’t work.

Good luck!

1 Like

Interesting, thanks! — I hadn’t thought of using a Mac/Win computer as streamer!

I reported a similar issue here —> (comforting to know I am not the only one)

The issue for me is I’d like to send 2.0 content to all 8 channels. At best I am getting 2.1. However, my 8 channel FLAC files do play correctly…

Aha. How about using Roon’s procedural filtering to route/copy L/R stereo to the other empty channels?

Those little all in ones with Windows pre-installed for about 200 USD works. You will only be loading the drivers and RoonBridge.

I’m going to try this later this afternoon. Thank you!

@Rugby – interestinger and interestinger! – thanks! (And just to make sure I’m understanding – these would handle multi-channel, is that correct?)

You can not split channels, only re-route.

Hi tried the Procedural EQ settings and they worked perfectly. Thank you @mitr!

1 Like

Hi, John, how is the ticket processing at the support team?

Hello @regeli,

We don’t have a “resolution” just yet, but I can tell you what we’re up to.

We’ve been looking at the “5:15 A.M.” track and performing listening tests on a variety of gear. We’ve noticed that some receivers appear to have less headroom than others which could be a mechnansim for audible distortion.

Two things that we’d like for you to try out:

A) Go to the DSP settings for the HDMI output zone, open Sample Rate Conversion screen, change DSD to PCM gain to +0.0dB.
B) Go to the Device Setup screen for the HDMI output zone, click “Show advanced”, and then set the maximum bit-depth to “24”.

Let us know if this changes anything for you.


I’ve bought the Nucleus since I was told by the dealer this was a “plug & play” solution.
In the end and how I see it goes now, it’s more and more experimenting and try/fail different settings.

I’m now using the Sony BD player as a Multichannel player to my receiver without any issues so far.

1 Like