Nucleus and Tidal - intermittent signal cut out

Hi Folks, wondering if anyone can help me. I just purchased a Nucleus to replace my Bluesound Node 2. I’ve successfully connected the Nucleus and all appears to be working fine EXCEPT when I stream Tidal I’m now getting music drop outs every minute or so for a fraction of a second. I never had this issue while streaming Tidal through my Bluesound. At present, I do not have any other music sources to draw from.

The Node 2 was connected to my Rotel RSP-1582 via optical cable. The Network card on my Rotel no longer works so I have connected the Nucleus to the Rotel via HDMI. I’m wondering if the HDMI connection is the problem or if it’s something else. Has anyone else experienced this issue? If so, any guidance as to how this can be fixed would be appreciated!

Hi @Roger_Swierstra

Does this same problem occur if you play TIDAL content to System Output of a remote device?

Can you try settings Google DNS on your router and let us know if that helps?

Dylan, thanks so much for the speedy reply.

First, I changed the setting to Google DNS on the router just to be safe.

Then I redirected the System Output to my Bluesound Node 2. The dropouts disappeared completely using both Tidal and playing songs from the internal SSD in my Nucleus.

So am I right to find conclude that the source of the problem is either my DSP (which I am imminently replacing) or the DAC within?

Thanks again.


Hi all,

I was having a very similar Tidal playback issue. I run Roon on a Mac (Mac#1) as my core and a second Mac (Mac#2) for playback (both modern 2020+ Macs, fiber 300mb+ up/down). Tidal playback has worked great on both machines until a few weeks back, then it became problematic. Tracks would either not load (basically timing out) or they would play for 20+ seconds then skip to the next track. I was pulling my hair out trying to troubleshoot. Tidal app would play fine.

Then I did a total password reset across all my devices and everything has been running perfectly since. I suspect there was some type of authentication issue with Tidal / Roon.

What I did.

  • Logged out of Tidal on my 2 Macs via Roon > Services > Tidal setting
  • Quit Roon on both my Macs (no tidal app running either fwiw)
  • From Tidal’s website I reset my password
  • Back to Mac #1 Roon Core > Roon > Services and logged in with new password
  • Mac #2 Roon > Services and logged in with new password

All good now!

Hope that helps