Nucleus and upsampling

I’m currently testing a Nucleus in my system. Roon core is usually my Mac mini 2019 7 core 16 ram. No problem, ever, with the mini upsamplmg max DSD. I usually leave upsampling at PCM max x 2.
I have been pleased with the Nucleus - faster rendering of data on iPad and phone and most pleasing a pleasantly improved SQ with upsampling set to max pcm x 2.
However I have had instances (doesn’t matter if song is off internal drive, external ssd or TIDAL) where the song plays with massive static & ugly noise, is clearly not listenable. When I go into DSP and revert to “compatibility only” the song is fine. When I then refer back to pcm max x 2 in the song the song plays fine.
Is this telling me that the Nucleus isn’t really up to upsample to PCM max x 2? The static also occurs at PCM max. It isn’t the DAC or network (all Ethernet) as I have never had this happen before using previous Mac (before my current Mac) in the 5 plus years I’ve been using Roon.
I was all set to keep the Nucleus but I’m now not so sure. Seems like I need the Plus to be sure of any upsampling
I have 3052 albums,

What is the nucleus feeding and over what connection?

Thanks for reply. Everything is the same apart from the Nucleus. I just want confirmation or otherwise that the Nucleus struggles with upsampling to max pcm.
I don’t think it is necessary to dig into the system, just a distraction from the Nucleus not being the answer.

The DAC isn’t locking on. This is probably happening during a change in file resolution. It should be fixable by making a change in the setup for your DAC. Try adjusting the resync delay, it’s default is 0. Try 100ms.


Thanks Henry, I will try that. Is that set up for DAC in Roon?

Just found where.

Tried that up to 2000 same result. However when back at 0 and pcm max x 2 still same problem, then convert on play to compatible only and all is fine then back (in play) to pcm max x 2 and song is fine.

Pity it seems the Nucleus lacks the grunt for what I thought was an unsample that I thought would be ok on the Nucleus. My 2013 Mac Mini never missed a best upsampling to DSD in Roon. Wanted to make it work as, although not massive, there was a really nice improvement improvement in the SQ with the Nucleus - which surprised me.

It’s not grunt but likely a Linux issue with your DAC you don’t state what DAC your using . If you check the signal path in Roon if your processing speed is above 1.5 then you are fine power wise and this is not the issue. Not all dacs play well in Linux with sample rate switching which is likely the cause here. Check your dacs support for Linux.

1 Like

Thanks for your reply. Processing speed is 11x so that does seem ok.

Both DACs are Roon tested and the both streamers (SOTM -sms 200 ultra) are Roon Ready

The Denafrips Pontus II is ok and plays fine upsampling

The DAC where it is upsampling inconsistently is a Project Pre Box S2 Digital which is Roon Tested , so I would have thought it would play ok with a Roon Nucleus.

It seems a weird problem as there are plenty of times (I have only had it going for three days) it upsamples ok. Tidal tracks , internal storage and external. I thought it might have been a connection issue as it doesn’t happen as much or at all with tidal tracks and more. It also seems to have coincided with formatting an internal drive on the nucleus but this might be a coincidence. It is a really ugly sound - it isn’t clicks and pops. It might just be a faulty Nucleus.

Strange too, how when I downsample within the songs and then re upsample it always plays fine. I don’t want to live with that though and I need to decide wether or not to buy.

Does anyone know if it potentially a wiring issue within the Nucleus? Altogether this might not explain why it works beautifully on the main system.

Then it’s definitely an issue with that DAC then, perhaps try a different USB cable? What’s directly connected the DAC the Nucleus or via the SoTM? If the SoTM that’s odd if it worked with the Mac as what core you use really should not affect a network endpoint.

1 Like

Something is amiss, and it isn’t necessarily a Nucleus problem, more an issue of setup. Another potential option is to increase the buffer size in the advanced setup or limit bit rate to 24 bits in DSP. The very best DACs only get to around 22 bits resolution so you don’t lose anything by limiting to 24 bits.

1 Like

Thanks, yes it is weird as it is not a consistent problem either. The nucleus is Ethernet cable into English Electric network switch which is out to SOTM sms 200 (with LPS) then curious usb cable into ether usb regen (with LPS) out with curious usb cable into DAC.
Nucleus is brand new, btw. Purchased by someone who had never streamed and used it for one hour tops.
All has worked flawlessly upsampling to DSD or pcm for years. I actually have two of the project DACs I might swap the other one in and see if that makes a differnce.

Thanks Henry, I will try that. I get why it doesn’t seem a Nucleus problem but it is the only variable in the system. I wonder is there any potential with the files themselves be served from the nucleus. Problem seems less with Tidal files.

Henry, just retried the resyc from 0 to 1000 in dsp and replaced the DAC (I have two of the same) and the problem persists.

Don’t use that with the DAC you’re having trouble with. Try either 384kHz or 352.8kHz only.



Thanks Peter. Yes, I thinking I am coming to the conclusion that I simply cannot up sample with the Nucleus and my second DAC like I could with the Mac Mini as core. Which is disappointing for a Roon product matched with Roon ready and Roon tested gears. Obviously the DAC is capable to upsample to max x 2 PCM, it also has native DSD, MQA & I have upsampled 512x DSD in past with Mac as Roon core.

I suppose playing upsampling to 384 (which seems to be working consistently) is unlikely to sound any different on this desk system (Project DAC) & Dynaudio powered speakers anyway. It just a little puzzling and - you know who it is - we just like to have all options.

I now need to decide whether or not to buy the Nucleus and accept the downgrade in performance in the system as opposed to the increase in performance in the main system and the ease with which Arc accessss sorted files remotely with the Nucleus in place.

What are the dsp settings down further for parallelize sigma data and native?

Your thread seems to be a good example why it’s highly recommended to completely describe all system components, interconnections and setup details with the opening thread, in order to quickly and effectively get to the root causes of a problem.

After many fruitless posts into the thread I now read, that you’re using several audiophile grade paraphernalia - nothing condemnable about using those actually, please don’t get me wrong!

But some designs are not really strictly adhering to the respective interface standards, just to make a difference.

Now the rub is, that i.e. different physical USB implementations may be more or less tolerant to edge conditions, and that’s why you now face inexplicable problems with specific components, after changing one variable.

It’s probably neither desired nor very convenient, but I’d recommend to start and replace your USB cables with standard, cheap ones to see if they make the difference.
Next would be to reduce ancilliary component count, or if absolutely needed to be able to make a connection, replace i.e. with a non-audiophile standard switch.

You may even have to go as far as testing USB directly from core to DAC, just to check functionality…

Good luck :heavy_heart_exclamation:

1 Like

Same as shown in your screenshot.

And I mainly listen to vinyl! So simple!