Nucleus+ became invisible on network

Roon Core Machine


Networking Gear & Setup Details

Rogers Ignite (identified as CGM4331COM) server

Connected Audio Devices

Nucleus+ Ethernet to router. Nucleus+ to USB: PrimaLuna Evo 100 Dac.
Dac to Amp: PrimaLuna Evo 400

Number of Tracks in Library

10,000 tracks

Description of Issue

Nucleus had been working very well. Then 1 morning , nothing.
Nucleus doesn’t seem to be connected to network. It was working 12 hours before and nothing changed during the night.
I tried connecting the Ether net cable to a tester and then to my laptop. No problem.
What to do?

Can you get to the web ui page? Probably not if its not connecting to the network.

Can you connect a HDMI monitor or TV to the Nucleus to see what messages are displayed when it’s powered up?

Good idea. But, no joy. Tried both HDMIs
Does Roon tech support monitor this channel?

@John_Berrie, how old is your Nucleus and from where did you purchase it? If it remains under warranty you should be able to contact your dealer or Roon for assistance.

Nucleus B. Bought 2.5 years ago. So out of warranty.

Is there a way to contact technical support?

Roon’s support team reviews these posts. I am tagging @support to ensure they are notified about your issue.

1 week since my original post. No news from tech support.
Not long after I paid for lifetime membership. Maybe not a good investment !

Hey @John_Berrie,

Ben here with the support team, thanks so much for your patience while we continue to navigate through each thread.

Following up, I wanted to first confirm: when you connected the Nucleus to a TV or monitor via HDMI, did you make sure that the Nucleus is still connected to power and Ethernet, and that the power
button is pressed so it should be turned on?

Can you confirm the Nucleus is powering on? Are any lights activated when the Nucleus should be on? If not, do you by chance have another power supply cable you can test?

If your Nucleus is turning on, but you can’t see anything pop up on the monitor, you can also check the internal LEDs.

More information about the failure can potentially be found by opening up the unit and taking a look at the LEDs while it is connected to power. Unscrew the bottom panel and look at the LEDs. You will have a Power Switch LED and a Green Motherboard LED.

I’ll be on standby for your reply. :+1:

Hi Benjamin,
1/the monitor says No Signal on both HDMI out Nucleus is on, Ethernet cable connected.
2/power is on, both Ethernet LEDs are on
3/ after opening Nucleus, both green and white LEDs are on
No HDMI out
All LEDs on

What next?



Hey @John_Berrie,

Thanks for the update! Are any of them flashing in a pattern? Becuase all LEDs appear to be on, the next step here would be to try a battery reset. We have video with instructions here:

Note that you will need thermal glue to perform the above. If this doesn’t help, or, you would rather send it to Roon for repair directly, I can follow up via PM to get an RMA started for you. Depending on when you purchased the Nucleus, a service fee may be required for the repair.

Let me know, John!

I will buy thermal glue this afternoon.
Also, I am in Canada. The Canadian importer would need directions from you to fix my Nucleus, if it needs further work

Hey @John_Berrie,

Thank you for the heads up on this. International RMAs typically need to be handled through the dealer/distributor where it was initially purchased.

Problem is that I bought it in France. And I am now living in Canada !

Got it, thanks for giving that a try @John_Berrie. I will follow up via PM with next steps. Please keep an eye out for a message from me. :+1:

It is out of warranty. So the Canadian distributor will have to handle my Nucleus. He would have to get instructions from you.
Thanks again

still no PM!

Hi @John_Berrie,

I have sent you a PM yesterday at 10:22 am PST. Please double-check your messages, thanks!

1 Like