Nucleus can be pinged, but won't connect to remote or the web interface

  • Details on your Core machine (OS, Hardware specs, Roon build)
    Nucleus+ Rev B, SN: 54B2038D88D8, version 1.8 (I believe it completed the update but it may actually still be on 1.7. See below). This nucleus was purchased from the Roon store on Amazon last year.

  • Details on your Remote(s) (OS, Hardware specs, Roon build)
    iMac 2019, Roon 1.8, iPad 2019, Roon 1.8

  • Networking details
    Linksys MX5300 WiFi6 wireless hub. Nucleus plugged directly into hub. All remotes haven successfully been connecting to Nucleus via Linksys wifi for the past 9 months until update.

  • Audio devices in use
    NAD 388i, wired directly to Linksys and accessed by Nucleus+ over RAAT

  • Library details
    About 16000 tracks are in library across Tidal and a Seagate SSD in the Nucleus+

Unable to connect to Roon from any remote device. Unable to connect to web interface directly through web browser.

The Roon was attempting to update (I’m not clear if it completed the update to 1.8 or if it is still on 1.7 but the remotes auto updated to 1.8 and I had set my Nucleus to auto update). The first thing I noticed was that Tidal got disconnected - so I reconnected Tidal. I believe this was before the update but it was the first thing I noticed that went wrong. The next day I noticed I could not connect to my core on either my imac or ipad. These devices have no trouble connecting to any other devices on the local network (the NAD 388i, apple tv, etc all going through the same Linksys hardware).

I tried to configure the Roon OS Core, and no luck finding it.

I tried connecting to the ip address to access the web interface, and server connection was refused.
I tried pinging the same ip address from the imac, and it successfully was pinging the device.
I tried connecting to the internal storage via connecting to the network server through Apple OS as I have in the past and no luck.
I tried rebooting the Linksys and iMac and ipad, all behavior stayed the same.
The NAD typically recognizes that there is a Roon source when the Nucleus is running, the NAD (which is hardwired) does not detect the Roon source.
I tried rebooting the Nucleus, eventually by unplugging it for 60 seconds and plugging it back in, no luck.
This isn’t my first rodeo trying to diagnose a Nucleus that isn’t working so I also hooked up my Nucleus to a TV. The first screen while booting looks like this:

And then the final screen looks like this:

So that. felt pretty promising - but come hell or high water, there’s no way for me to connect to the web ui via that URL/ip.

So I’ve done all the tricks I know to try and make this work. Any suggestions as to where to go from here would be appreciated.

It doesn’t work if you try connecting to when you have that screen up?

Roon 1.8 can not affect Roon OS at all, to which the web UI belongs – something else is amiss here.

Was this ever configured to be static IP? You can always type “resetnetwork” and hit enter at the console screen shown in the second screenshot to reset network settings.

Nope, going to that IP address with that screen up doesn’t work and nope, have never configured any of this to have a static IP. I’m happy to try to see if resetnetwork works though - but have never done anything other than default settings.

I assume you have attempted to reboot it, and maybe your switch/router?

I also would check the IP of your laptop to make sure its’ on the same subnet.

Also, have you tried to ping your nucleus’s IP?

If you can’t, that means something is wrong with the network between your machine and the Nucleus, as the Nucleus can clearly get an IP via DHCP from the router.

Hey Danny, thanks for your help.
As mentioned in the original post, I’ve rebooted both the Nucleus (several times) and the switch/router. I also was able to ping the ip from the iMac so I do believe they’re on the same subnet. I’ve also confirmed through the router that everything is assigned the right IPs, there are no conflicts, and they’re all on the same subnet.
Any other ideas?

@dylan Ever seen this?

The web UI is part of the core operating system and cannot be corrupted as it is on a read-only file system in a squashFS.

I’ve never seen this not be a network issue.

Usually people can’t get an IP address or the machine is configured with a bad static IP. That’s why I had you check that route first. An IP conflict is another case, albeit much less common. You already checked that as well.

If you turn off the nucleus, and then turn off whatever gives out the DHCP addresses, and then turn on the nucleus, do you still have an IP? If you turn on the router at that point, do you get an IP that’s different than the previous IP?

Yeah it’s a head scratcher. I definitely feel you that it feels like it should be working and I’ve tried 1000 things 18 ways to sunday and can’t connect to it.

The Nucleus doesn’t have an IP in the first scenario you described - it says it’s waiting to get an IP address. When I turn on the router, it assigned the same IP as always.

I then decided to try a few different things. I reserved a different IP for the Nucleus in my router settings ( and the Nucleus pretty immediately picked up the new IP. The old ip ( no longer pinged and the new ip pinged correctly.

Then for fun I ran an nmap scan on my router IP ( to make sure this imac could see open ports on my router web UI interface…then I tried the new Nucleus IP ( and it said it’s up, but no major ports were open which would include port 80. And then I just double checked that this IP was resolving to my Nucleus’s mac address by using an ARP command. See below for the output of these 3 commands.

Then I just double checked my router settings to make sure that mac address was, in fact, the Nucleus’s address.
Screen Shot 2021-02-16 at 1.29.44 PM

I tried accessing the web ui from the ipad again, no luck. I tried turning off all firewall settings on the imac, no luck. I tried putting the Nucleus even into a DMZ for the local network, no luck.
I’m completely out of ideas at this point. Short of the ethernet hardware failing in an incomplete way, I can’t guess what’s causing this. But at the end of the day, if port 80 isn’t even up on the device, I don’t think there’s much more I can do since the port should show as available with nmap if the service was actually running. Any other ideas?

Don’t know if this will help or if you’ve tried any of this - are you able to swap out the cable between your router and nucleus trying a different network cable? Also have you tried connecting the nucleus to a different network port on your router?

Thanks for the suggestion! I just now switched the cable and port to a cable and port I am 100% certain is working - and unfortunately the same behavior on the Nucleus continues.

@danny @dylan I’m pretty dead in the water here. Is it time to send the Nucleus back as it’s still under warranty? Do you have any other things for me to try?

Do you have a backup? Can you access the smb share on it?

We can try another thing if you have a USB stick… it’ll be faster than sending it in and having me do the same thing…

Yep it’s backed up. But no, can’t access the smb share on it unfortunately - all ports are closed.
I’m totally down to try a USB trick at this point.

Just wanted to close the loop on what happened next as it seems a few other folks are having this problem.

Danny reached out to me in private message at this point. He had me then try to make a new SSD with the operating system on it to replace the one in the Nucleus. I had the same behavior after I tried that (though, there’s a good chance I may have done something wrong in the process). Ultimately they sent me a brand new SSD to replace the one on the motherboard. When I installed that, everything was working perfectly again and has worked ever since (this was several months ago now).

My guess is I had a bum SSD - but never really heard a conclusion as to went went wrong. In any case, hats off to the Roon team for getting my situation resolved. Hope this helps anyone with the same crazy behavior.