Nucleus can not connect with my NAS

Roon Core Machine

Nucleus
Operating System: Version 1.0 (build 227) stable
Roon Server Software: Version 2.0 (build 1133) production

Networking Gear & Setup Details

Mixed network of windows PC’s and Macbook Pro
NAS QNAP TS-431P2

Connected Audio Devices

Linn Accurate DSM

Number of Tracks in Library

5000 tracks

Description of Issue

My Roon Core can not find my network share on my NAS. I can connect to the share from my windows machine, from my Iphone, from my Ipad and from my MacBook. The Roon Core can not find it. The password does not contain special characters, only small and large letters and numbers.

The enclosed document contains some screen shots.



Have you tried replacing TS-431P2 with the ip address of the NAS?

I did. Sames result, no connection.

So you created a user named Nucleus on the NAS and made sure he has access to the (system default) multimedia share?

You checked that the password for Nucleus doesn’t contain special characters (read: FAQ: What’s the best way to configure my NAS for Roon?)?

What are your general settings for Microsoft networking on your NAS (the advanced settings you already shared in your first picture)?

This option seems to be unforgiving (and is not default on my NAS):

grafik

What if you login with the Nucleus user directly on your NAS? Can you see and access the multimedia folder and its sub-folders?

Please check User, Group and Shared Folder settings/permissions in Control Panel > Privilege too.

1 Like

Hi @Jan_van_Rooij,

Another thing you can try along the lines of @BlackJack is to try using Guest for the username. It would certainly help with narrowing down the possibility of authentication errors.

Thanks,
Wes

Blackjack, the answers to your questions are:

  1. Yes I created a user named Nucleus on the NAS. Multimedia is shared as only folder with read/write access. When I login as Nucleus I can only get to the Multimedia folder.
  2. The password only contains capital and normal letters and numbers.
  3. Normaal settings, See enclosed screenshot. And yes, when I ask Roon to connect I do also enter the workgroup.
  4. This for SMB folders can not be changed when ABSE is active for shared folders. I can only change it when I deactivate ABSE for all shared folders. ASBE =access-based shared enumeration. It means that when enabled, users can only see the shared folders that they have permission to mount and access. Guest account users must enter a username and password to view shared folders. It is de default setting on my NAS.
    @Wes: I create the ‘gast’ user with also only access to the multimedia folder and no special characters in the password. That didn’t’t work either.
    Finally one additional command that I forgot to mention earlier; Apple network (AFP) and Time Machine are active on my NAS as I need to access it from my Mac.

What are your share properties?

image

Do you have SMB Encryption turned on?

image