Nucleus can't "enable" Gryphon Diablo amplifier

Hi, I have just purchased a Roon Nucleus core, and a Gryphon Diablo 120 amp, and connected with an audio USB cable. I have set up Roon, and the Nucleus can see that the amp is connected. However, when I click “Enable” it respopnds “enabling…” and nothing happens. I have tried siwtching on/off, I have switching on the Nucleus first and then the am p, and vice versa, but the same problem happens. This is very frustrating. Do I have to download a new driver? Best regards

I’ve moved this post to the “Support” forum, and have flagged @support for you. They should be able to help you further.

Thank you for your report, @Kai_Grotterud!

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

In addition to the diagnostics report, there is some other information that would be useful to the technical team’s investigation:

  • Have you tried a different USB cable?
  • Can you confirm that you are able to enable other audio zones?
  • Are you able to play to the amp outside of Roon?