Nucleus+ connection setup problem

Core Machine (Operating system/System info/Roon build number)

Nucleus+ / Build 175

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

QNAP TS-251 on ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Auralic Vega via USB

I have a replacement Nucleus+ that I’m trying to connect. I had a similar problem with the first unit of not being able to connect to my NAS. Here is a screenshot:

The user ‘Roon Nuc’ is set up as a user on my NAS. This is what made things work before. I’m using the same password, though I have tried changing it to a very simple password to no avail. I have tried using the network IP address of the NAS. I have also lowered my firewall and I added the IP address for the NUC as an “allowed connection”. I have also changed my NAS to allow all connections. I’m about at the end of things I can think of.

I assume you also set access permission for the Multimedia share for the new user. You might want to check that.
Modifying User Account Information
Editing Shared Folder Permissions

Yes, I have access.
image

Finally got connected. Had to simplify the password for access. What’s puzzling is it wouldn’t take the same password I had before. And why it has to be simple?