Nucleus+ core machine is not recognized

Core Machine (Operating system/System info/Roon build number)
Roon Nucleus+ Rev B - just purchased two days ago through Amazon

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet through netgear switch (which is working fine)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Haven’t got that far.

Description Of Issue
Can’t get past step three on quick install.

Nucleus+ core machine is not recognized. Roon app keeps searching for Nucleus core (allowed 20 minutes), but can find Nucleus+ machine.

The power light looks good. The ethernet connector on the back of the Nucleus+ shows flashing green on right and stationary yellow on left.

The unit makes a subtle, almost silent, whirring noise that repeats over and over, but no connection or recognition by Roon remote devices, (PC, pad, etc.) I think I just have a bad unit.

Have you tried to connect to the web interface?

No, not sure how to do that. Can you explain?

That’s not a safe indicator for the device to be powered on. Since this has happened before: you’re sure the unit is powered on? According to the knowledge base, the power light should be a dim white light.

The power light IS a dim white light, so this looks good. The ethernet connector shows flashing green and stationary yellow (separate item from power light)


Can you check somehow if the Nucleus shows up on your network? Like: checking if it appears as a device on your router’s management interface? There, you’d also find out what IP address the Nucleus got assigned - this could be used to connect to the web interface, too.

I guess you’ve already visited this page:

Thanks for the advice. I checked my network admin page (eero), and the Nucleus+ doesn’t show up. All my other devices do (laptops, pad, oppo, etc.). It appears that something is not working with the internal ethernet hardware of the Nucleus+ unit.

Maybe you could try a different ethernet cable? Just to make sure it’s not the cable?

Yes, thanks tried three others that work fine with other equipment.

New or used? A used device’s network configuration might be incompatible to your network.
What do you see if you connect a monitor/TV to the HDMI port of the Nucleus+?

This was purchased as a new unit. That said, I see the following when I connect the HDMI A connector to a TV monitor:

Manufacturer: Roon Labs
Model: Nucleus+
OS: RoonOS 1.0 (build 175) stable
Serial: 54B2038D0E59
Hostname: NucleusPlus

Roon OS Web UI can be directly accessed at:

Does this tell me anything? Should I try to access the web address?

Generally yes as the message on the TV reads so but the network address that you provide here is not one out of any range of reserved addresses for private use. Please check your network settings on the router again to make sure that you don’t bridge the Nucleus+ to the internet.

My last idea would have been: have you tried connecting the Nucleus directly to your Eero device - without the Netgear switch you’ve mentioned in between?

But first I’d suggest to follow up with what @BlackJack suggests. :slight_smile:

1 Like

You kind of lost me on your last response. The network settings on my router show my address as What do you mean by checking the router to make sure that I don’t “bridge” the Nucleus+ to the Internet? When I bought this unit, I thought it would be an easy set-up. This is fast becoming a cluster…

I tried connecting directly to the ethernet jack instead of through the netgear switch. Didn’t help or change anything. It should all be easier than this…

The nucleus+ is such an elegant unit. I was really excited to get it rolling today. Instead I’m looking at packing it up for return. That’s the way it goes sometimes…

It is, most of the time. Sorry that it’s not working for you. :frowning: is a host address out of a range of reserved addresses for private use. What you refer to when you write “my router show my address as” is unclear. I don’t use Netgear products so I’m unable to help you further here.

Thanks for the kind words. I have followed the roon community messages for quite some time. Folks are pretty nice and helpful. I look forward to messaging when everything is closer to working. Thanks for the support. Hopefully, they can just swap this out for another new one with little hassle. Take care and be safe.