Nucleus crashing on Roon 2.0

I just found this thread after my own frustration with crashes on my Nucleus. (with the new upgrade)

I hesitated to upgrade to 2.0, but finally did, now to my dismay.

I have dumped my database and restarted the entire Config for the Nucleus. Even after the full restart, I still had the Nucleus not last 12 hours before it crashed again.

I will definitely be researching how to downgrade the software so I can get things stable again.

Man this sucks.

So I followed the Nucleus instructions for how to downgrade to 1.8, and it didn’t do a thing. It is still running 2.0

This time I am going to try and run only local music, and not add Tidal integration to see if the instability may be caused by Tidal somehow. Grasping at straws I know, but I may as well try something different to help this thing stop crashing.

This may seem counterintuitive—and I’ve posted about it elsewhere on this forum—but what worked for me was:

  • first to downgrade my remote to Roon 1.8 legacy (instructions in the Migration FAQ);

  • (this is the critical part that is missing from the FAQ): leave open the legacy remote, notionally connected to your Nucleus, while attempting the legacy downgrade on the Nucleus.

The latter was what made the downgrade ultimately work for me (having tried and failed a number of times). Obviously you need to follow the remainder of the FAQ as well.

I hope this helps.


Hey @Chris_Heilig ,

Thanks for reaching out and sorry to hear about the issues here! I’ve activated diagnostics on your Nucleus and I am seeing some strange logs that appear to abruptly end.

I noticed that there is often Analysis being performed when this happens. Can you please try to go to Roon Settings → Library and temporarily turn off Background and On-Demand analysis and see if this changes anything?

I would also advise making a backup of your Roon database and then trying an OS reinstall from the Web UI if you haven’t yet:

If you still want to downgrade to 1.8, please provide some info on what steps you took and a screenshot of the branches folder, thanks!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.