Nucleus+ Died- not a lot more to say!

Roon Core Machine


Nucleus+ Serial # 1803 I 700106)

Networking Gear & Setup Details

Ethernet cable from Nucleus+ goes to a switch, then to a Lumin X-1.

Connected Audio Devices

Ethernet cable from Nucleus+ goes to a switch, then to a Lumin X-1.

Number of Tracks in Library


Description of Issue

The Nucleus+ has been working perfectly, unit today.

Found the on/off LED not coming on, checked the ZPS, it’s working. No flashing at the Ethernet port.

Hi there
Not support but that does not sound good.
Let’s tag @support for you here.
Do you recall where you purchased it and how old it might be?

1 Like

Your earliest post of Nucleus was in 2019, so I assume the warranty has expired.

You have been using a LPS right? Please find and use the stock Nucleus SMPS to see if it boots with the SMPS or not.

Connect a HDMI cable from Nucleus to a monitor TV. See if it shows text on screen when you power it up.

Assuming it does not, power down the Nucleus, disassemble it, remove the m.2 boot SSD. Then power it up again. If some text is shown, your m.2 boot SSD is dead.

I bought it about 4-5 years ago from Sun Coast Audio, so I expect it is out of warranty. This happened once before, about 3 years ago, and I had to send it to Roon who fixed it.

Hi Peter: I do love my Lumin, but miss the features Roon provides. Yes, I am using a LPS. I will be traveling for the next week, so I won’t be able to run the HDMI test. until I return. I did try the stock SMPS, same result.

Warranty is 2 years unless you bought some sort of extended warranty.

Hi @Tom_Bourret ,

Do let us know what your HDMI says when you get back. If there’s no HDMI output, we’ll need to have the unit sent in for an out-of-warranty RMA repair.

Hello Noris- I’m finally back and did theHDMI test. Nothing appeared on screen. Thus, I suspect I need to send it to you for service. I realize it is out of warranty and I will need to pay for the repair. No problem. Please send the Return Authorization. Thanks, Tom

1 Like

Hey @Tom_Bourret,

Thank you for letting us know. I will follow up via PM for next steps on getting an RMA started for you.

1 Like

Is it not powering on!

Have you tried the basics?
Have you checked to see if it’s plugged in at the wall?
If the power cable has a fuse, is it ok?

If still nothing, unplug it and open her up. Check the power supply cables inside in case something is loose.

Could be the power supply
Do you have a spare power supply for it? I think is 12 to 19Volts, the plus is 2.5ID and 5.5OD and 11mm long.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.