Nucleus+ doesn't boot after brief power outage

Roon Core Machine

Nucleus+ (rev B)

Networking Gear & Setup Details

Linksys MX5300v1

Connected Audio Devices

Pro-ject S2

Number of Tracks in Library

30,000 tracks

Description of Issue

Briefly lost power to the device. The device does not seem to reboot. The device has been great for the past year or so. Upgraded to 2.0 w/Arc no problem.
Power light turns on/off, ethernet cable has blinking lights. But no matter how many times I reboot (holding short or long on power) does the machine ever come back.
I’ve tried hooking up an HDMI cable (as I have in the past with previous issues) and nothing displays (though it does detect that the cable is plugged in, no signal is sent).
I’ve tried unplugging and letting it sit with now power for a long time and plugging back in.
I’ve tried unplugging everything.
I’ve tried unplugging the SSD inside and reseating the RAM.
Same behavior.

It looks like many other people have the same issue… (like Nucleus+ will not connect after brief power outage (again!))

Hoping someone can help. I bought this back in May 2020 so really hoping it’s not a case of “oh yeah it died, time to buy a new one every 2 years at $2500 a pop”.

Unfortunately it does sound like the SSD may have failed especially if there is no video display at all via HDMI.
Also it’s the weekend and Roon support will probably not be able to take a look at your case until Tuesday.

An UPS comes at a fraction of the price of a new Nucleus(+) and can protect your device from the consequences of short power outages and power surges – something to think about adding to your setup?

Thanks - I’ll cool my jets until Tuesday. Hopefully they’ll have a solution for me.

Sure - hindsight is 20/20.
Surely it shouldn’t be the expectation that the Nucleus fails so regularly due to a simple power failure. If it’s that sensitive, they should prominently put in their user manual that a UPS is required to avoid product failure.


Any electronic equipment can get fried when the power comes back on. I recently had a whole house surge protector installed. I hope it does some good.

I love how this community blames the victim here. I’ve got an extremely high end surge protector so not really sure your point. Most electronics don’t require UPS and if they do, they specify that in the manual. Given how many other people on this forum have this issue with the Nucleus (particularly recently), its refreshing to see how easily you all dismiss it as user error. Thanks for the help folks. I’ll just wait for support to respond from here on out.

1 Like

You said you had a power failure and then the Nucleus would not boot up.

I’m not sure what a “high end” surge protector may be, but if it wasn’t designed specifically for computer electronics, its thresholds may be to high and/or its attack times to slow to effectively protect computer electronics.

The filesystem of any computer may also get corrupted when there is a sudden power loss. As Roon OS is a closed system, I don’t know how good it may deal with such a situation. While there are many similar posts like yours, I never saw Roon Labs comment on the actual failure/failing device/part. So it can be a fried power supply, a damaged motherboard, a corrupted filesystem or a failing boot drive (during runtime, there is probably not much need to read data from this drive so some failure types might be unnoticed until the next restart {attempt}).
As you offered a short power outage as reason/starting point for your current issue, I just offered to think about adding a device (UPS) specifically designed to deal with such a situation. I don’t see this as blaming the user and given the uncertainty about the actual failure, even if you had one it might only have delayed the appearance of the issue until a later time – or it could also have totally saved you from all your current trouble (and is still much cheaper than a new Nucleus).

My Nucleus+ continues to be dead. Any help from someone in support?

It’s now been a week. Still have a dead Nucleus+. No response from support. Is there another process here to get help or do I just toss it in the trash and write a review how no one should buy these things?

Messaging you privately right now, @jager


1 Like

@jager, support are dealing with a large backlog of tickets following the release of Roon 2.0, and deal with all requests in order. They will get to you.

It looks like you’ve already performed some diagnosis, and can’t see any messages on a display, which as others have pointed out, is likely caused by a failed SSD. Since the Nucleus is out of warranty, you have options:

  • Source a replacement SSD, and install this yourself; you’ll then need to install ROCK before Roon Support can remotely flash this back to a Nucleus.
  • Return the Nucleus to the store you purchased it from, and ask them to carry out the repair
  • Ask a third party to perform the repair

If you require any further assistance, please let me know.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.