Nucleus+ failed to boot up after album page instability

Core Machine (Operating system/System info/Roon build number)
Roon Nucleus+, Serial #54B2038C104F, 4TB SSD
OS 1.0 (build 227), Server 1.8 (build 806)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
All devices are on the same network.
Netgear Cable Modem (Cox Gigablast up to 1Gb/s)
Apple Airport Time Capsule (latest FW)
Peakedge SE26 24 port GigE Switch
Netgear 16 port GigE Switch
Linksys 4 port GigE Switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Devialet D250 PRO v.13.1
Meridian: 218 (3u), MS600, Control 15 (2u)
AppleTV 4K (2u)
Airport Express (2u)
iMac 5K

Other Devices
Meridian Core on QNAP
Crestron Pro2 Controller
Crestron CNX-PAD8 (Audio Matrix Switch)
Crestron MT-MC2W Controller

Description Of Issue

Problem started after updating to the lastest Roon Core version and iOS App:

  1. Home: Added Album Page unstable, album covers flickering, some covers are appearing and disappearing in a loop
  2. I then went to the Nucleus+ settings, Power Restart the Nucleus+ Core, and the machine failed to boot up after numerous attempts. It’s bricked at this point.

I’d appreciate your help very much.

Best Regards,

Does it show anything if you connect it to a monitor on boot?

I don’t have a monitor that I can use. I access the Nucleus+ via the network on my iMac.

I saw on a different post another user hooked up a monitor via HDMI and didn’t work:

OK I moved the N+ to next to a TV, tried both HDMI-A & HDMI-B, no signals from the HDMI outputs. I then cycled power off/on a few times, still no signals. It’s similar to what the other user reported.

There’s no network issues. There has been no changes, and all other networked components work fine. I have a legacy Meridian Sooloos system on the same network & it works fine.

Contact your dealer then i guess.

The unit was purchased on 3/3/2020. It’s a couple of weeks beyond the 2yr warranty period, but I hope Roon will still honor it since the problems were caused by the latest Roon update.

I’m having the same problem. The Home added new album page became unstable after the latest Roon updates (Core & iOS), some album covers are coming on & off repeatedly. I went to the Nucleus+ setting web page to restart the machine, got a red box error message that it failed to load properly. It failed to boot up properly after numerous attempts, powering it on and off. Now browser says failed to open page.

It’s bricked now. I’ve reported it on a separate post.

I’m having the same problem after updating to the latest Roon version, and no signals from the HDMI A & HDMI B outputs either.

It seems to be caused by the new Roon updates. I purchased my Nucleus+ from a Roon authorized dealer, Sunny Components, on 3/3/2020. I hope it’s covered by warranty.


Hi @DN28 ,

I don’t believe that this issue is related to the update, this sounds like it could be a hardware issue. These symptoms sound like the SSD could be failing, but without seeing the system logs it would be hard to determine this for sure.

If you or your dealer can open the unit up and remove the M2 SSD, you should try to see if you get HDMI output with the SSD removed, this can help confirm the theory that there is a faulty SSD.

There is also a more advanced troubleshooting step we can try by performing a CMOS battery reset, but that would best be done by your dealer. I can send them the steps for this if removing the SSD has no effect.

1 Like

I’ve unplugged the SSD, tried power cycling several times, still no signals from both HDMI A & B. I believe it’s not caused by a faulty SSD.

I’m unable to get the log. My unit won’t boot up and there’s no signals from HDMI A & B.

It was suggested to remove the SSD in case it’s a faulty SSD. I’ve unplugged the SSD and the N+ still won’t boot up, no signals from HDMI A & B after multiple power off/on recycling.

Hi @DN28,

You have your own support thread where @noris has been attending to your problem:

So, why would you highjack another user’s thread?

What’s your problem? I was replying to @beka with some additional info. of the same issue.
Why are you even on this thread? Your post had zero added value.

First, this thread you responded to is marked as ‘solved’ and as such may stay under the radar of Roon support. If you wanted to involve @beka, you could rather do that on your own support thread which is still open and attended to.

Second, Roon support rightly prefer to keep any relevant info of a user’s support request on one single topic—his own.

And third, many consider thread highjacking as rude.

All good points especially the marked solution aspect which support would now tend to skim right over.

With all due respect please post in your existing support thread any comments or suggestions regarding your own particular issue.
It will garner more attention that way and we keep all of your support information in one place so it’s easier for Roon support to follow up with.

Thank you all for your cooperation and understanding

1 Like

Hi @DN28 ,

I’ve moved all your posts to the existing thread to keep relevant info in one place.

Just to clarify here, you removed the M2 SSD and the issue was still the same? The M2 SSD connects directly to the motherboard, and this is where the Nucleus Operating System is stored. This is what an M2 SSD looks like for reference:


If the behavior was still the same with the M2 SSD removed, you or your dealer can try this CMOS reset procedure, this has sometimes brought failing motherboards back to life.

Please note it is very important to apply thermal paste to ensure that the Nucleus CPU does not overheat, that step is not optional:

Hope this helps.

It looks pretty easy to do the CMOS batter reset but I’ve already taken my N+ to the dealer since you told me it’s better for the dealer to do it. Unfortunately, my dealer notified me today that they don’t feel like getting the thermal grease & “uncomfortable” doing the battery reset after charging me $200. They want to ship the unit back to Roon. I was told Roon quoted $190 to $800+ (if the PCB need to be replaced) to the service the unit.

I’m still unconvinced that the failure was not caused by the Roon update. It’s even more troubling if it was a hardware failure in such a short time. I’m very disappointed with Roon’s reliability & after sales service & supports. This whole experience with Roon has left a really bad taste in my month.

Hello @DN28 ,

Sorry to hear that the dealer was unwilling to try the CMOS reset and they still charged you, this does not sound acceptable.

As I have informed to your dealer, it sounds like the Nucleus has a hardware issue and if they are unwilling to try the battery reset, then it needs to be sent in for service to our service center where we can take a look over the unit.

I’ve escalated the case over to our RMA team and have asked that they include you on follow-up communication, let’s please continue the conversation over email.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.