Nucleus+ hangs on v1.7 build 528 download

Nucleus+, v1.7 build 521, RoonOS / Firmware version 1.0 (build 183), Vendor version 1.0 (build 12)
Hardware serial: 94C691125A5A
Clients (iPad, Computer Catalina) updated to build 528 fine
Core hangs on download screen and eventually returns ‘Download Error’
Tried multiple (6) reboots via core power and rear switch; no change. Waited patiently each time before next reset.
No update problems prior.
Your end or mine?

Hi @Robert_Nystrom,

Can you share a screenshot of the Nucleus Web Administration Interface?

If you reboot the machine from there is there any change?

Re-booted from interface, no difference- hangs, eventually shows very small progress bar movement. Then times out.
Nucleus+ Web Admin and download progress

Roon- Downloading attached.

Hi @Robert_Nystrom,

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link?


I have the zipped log file- about 7.1MB. I do not use or have access to dropbox. Another way, perhaps?

Hi @Robert_Nystrom,

You can upload the logs here:



Thanks for sending those over, @Robert_Nystrom — I’ve passed the logs along to the team and I’ll be sure to update you as soon as they’ve analyzed them and provided further feedback.

Core Machine (Operating system/System info/Roon build number)
Nucleus+, Roon v571, RoonOS b219
Mac OS 10.15.4, iPhone & iPad, ‘latest’ iOS
70% of internal Nucleus+ storage available (about 600 GB)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Wired ethernet to Linksys Velop router.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Wired ethernet to Mac desktop. WiFi to iPhone and iPad (duh). Wired ethernet to Naim Qb and wired to PS Audio DAC Sr.

Description Of Issue

Everything worked really well until build 521. Nucleus+ took many tries to update to 521. Progress speed was in the bytes per second range (no kidding). Sent you my logs after your requests, and never heard back. Finally sat up one night and kept prodding the thing to stay connected and the update eventually happened (hours and hours). Copying files to Nucleus+ internal SSD slowed way down when transferring files to it, but would complete the copy. Playback was OK.
Now v571. Download took forever again (hours and hours). Babysat it and eventually it installed. Since 571, audio devices will stop playing every 3 to 10 minutes for 5 seconds. Playback bar will stop in client (iPhone, iPad). Five sends later bar will jump to new ‘5 seconds later’ position and start playing. Went to add audio files to internal nucleus+ ssd, and no hope. Can create folders ‘quickly’ in mounted drive storage area, but then adding the actual files dies on the vine. Progress bar just sits at ‘calculating time’, with no progress. Hitting ‘cancel’ on the copy takes close to 8 minutes to actually stop the copy dialog.
I’ve done the usual re-boot, etc, no difference. Doing a manual backup seems to work fine.
Now what? Any clues?

Screenshots below:
Nucleus  Info Build 571

Hi @Robert_Nystrom,

It looks like there might be some networking issues at play here. How is the Nucleus connected to the network? What router is in use? Any other networking devices?

Is the content you’re playing coming from internal storage or a streaming service?

Hello Dylan-

I’ll try describing it again-

The router is a Lynksis Velop mesh type (two units). My network speeds from the ISP is >100 Mb. Router to nucleus+ is wired through a switch. Other ports on the switch only connect to wired Roon audio clients (PS Audio DAC Sr). The Mac desktop is wired ethernet to the switch. I also have a Naim QB that is wired to the same switch (not using WiFI). As a test, I have shut off all network traffic except the audio routing; no difference.

Skip happens with Tidal or local library files.

The wifi connections are to the iPhone and iPad Roon clients. The playback audio skip I described occurs with the WiFi clients (iPhone & iPad) OR the WIRED desktop.

When Nucleus+ does the updates, it is always a wired connection.

I have zero other network issues.

All the problems started with build 521. I realize there may be another problem with my setup that happened simultaneously. However, build 571 made it much worse. With 521 it was usable; with 571 it’s nearly worthless, skipping (going quiet, wait 5 seconds, start playing) every minute or so.

I do have one thought:

What if my Nucleus+ internal SSD is sick? I assume Tidal is buffered on the internal SSD.

Last night on my WIRED desktop to my WIRED DAC, I noticed that while
Tidal was playing, Roon would pop up a very quick message saying something to the effect that the “audio file was too slow”. It’s hard to say exactly because it happens so fast. I blamed Tidal.

I then switched to my library tracks on the SSD. It was now skipping every minute or so. I would get the same message about the “audio file being too slow” (again, the message lasts only a
second or so- tough to read). The connection from desktop to nucleus+ to DAC is less than 3 meters and is wired.

If my SSD is sick, I assume that would explain a lot of this. I noticed on the browser control page (you should have my screen shot) there is a format button for the drive. I realize it wipes the drive. If it’s just the ‘Internal storage’ folder, I can re-create that. BUT- does it also wipe the Roon OS and other operation folders, or is it only my media? Is there a way to re-create the folder structure if it takes out everything?

As I mentioned, backups to a separate SSD work as expected. If that uses the same drive controller, then that implies to me the internal SSD is sick.

If it is the drive, maybe a format will fix it, or maybe I should just swap the drive? Is that a viable path?

Wiping or replacing the SSD- how much pain am I in for? Is that the only way to rule out the drive?


Hi Dylan-
I don’t know how my thread was shifted from a build 571 discussion to an old 528 thread, but so be it.
I did some more poking around after my reply about a possible SSD failure explaining my nucleus+ symptoms. Well, here’s more:
Looking at the Data path, there are three volumes- Internal storage (SSD), USB SSD for backup, another USB flash drive for more backups.

  • I can create a folder in any of them ‘instantly’. I can rename it, I can delete it.
  • I can copy files from any of the three volumes.
  • If I play an audio file from ‘internal storage’, I get the ‘file reading too slow’ message on my desktop Roon client. Playback stops for 5 seconds, then resumes (most of the time).
  • If I attempt to copy a file (2 to 3 MB test file) to ANY of the three volumes, it either takes forever (hours), or fails completely. Pressing ‘stop copy’ takes a bit over 3 minutes to cancel the operation.
  • Maybe my Roon updates take so long (hours) is because the file is written to a drive, and my write operation is hosed?
  • Is my hardware hosed (disk I/O)?
  • Is it something in build 528 onward? 571 is much worse. Maybe my issue is just escalating.
  • How about re-install the Roon OS? It’s at v1.0, build 219
    Any help would be appreciated.
    Thanks, Bob