Nucleus+ has lost NAS

Hi Guys,

I’m having a technical problem and I don’t know how to proceed. My Nucleus can’t seem to find my QNap NAS any more. Not sure when this started as I haven’t used the system for a few weeks. I went to start it up this morning and it began playing the first song in a playlist and then immediately quit. Now it can’t find it. I have tried a hard re-boot of everything.

I know the QNap is still on the network because I can see it in the finder and access it with the QNap app. I haven’t changed the name of the path to music file which is \NameOfTheNas\Music > Artists. Red text says that the drive is not available, but when I do an “edit this folder” and then try to browse through + Add Network Share and paste the location of the folder that was copied from the “location” in the “get info” pop-up, it doesn’t find anything. This location is smb://NameoftheNAS._smb._tcp.local/Music/Artists

Also, when I try to play TIDAL to my Sonos (which Roon claims to see) I get the error “Transport. Roon lost control of the audio device.” Roon plays TIDAL to my Meridian 218 just fine.

I’m running Roon Version 1.5 (build 339) stable (64bit) on Mac High Sierra 10.13.6




Hey @Hal_Greene,

May I ask that you please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

So we can gain some greater insight into what you’re experiencing, please verify the following:

  • Instead of smb://NameoftheNAS._smb._tcp.local/Music/Artists can you try editing (note that it is important that you edit and not add a new watched folder) the path to be smb://NameoftheNAS/Music/Artists.
  • Has there been any change to your setup recently? Any different networking hardware? Any new apps that utilize the network?
  • Are you able to access the NAS via SMB from the Mac?



To answer your question:

There has been no change to the topology/hardware/additional apps that I know of. The path to the music folder is as you described. I can access the NAS in the finder just fine (it shows under “shared”). The Nucleus+ is hardwired to an Apple Airport Time Machine router while the QNap is hardwired to same through a TPLink TL-SG1016 switch. The desktop with the Roon software, a Mac Pro, connects through another switch, the TP-Link TL-SG108.

When I try to SMB directly into the QNap I get an error as described in the attached JPG. I am also attaching the DNS config.



Odd. Still couldn’t get the Nucleus+ to find the NAS this morning. When I enter the following into the address bar in Safari: smb://Name ofNAS._smb._tcp.local/Music/Artists the finder opens up the folder just fine. Typing smb://Name ofNAS/Music/Artists into the address bar fails. Then I thought of adding the network share as smb://

Success. Still not sure what’s going on but I’m still getting the error about incorrect DNS. That probably has something to do with it. And Roon still fails trying to gain control of my Sonos. Will get online with QNap tech support tomorrow.

So all 127k tracks were successfully added back into the Roon DB under the new folder share. I have verified that they are listed correctly with the right metadata. They play very nicely to my Sonos now, so that issue may be resolved. But the tracks in my saved playlists (which were based upon the previous network folder) remain unavailable. Is there a way to re-link the tracks? Thanks.

Hey @Hal_Greene,

I’m glad to hear that all of your tracks are back.

This can happen if a new watched folder is added instead of modifying the existing watched folder. We have a Knowledge Base article about the proper steps to take. The best option is, if you have a backup from before you added the new folder, to do the following:

  • Restore the backup
  • Remove the old watched folder
  • Add the new watched folder

By ensuring that the old watched folder is removed before adding the new watched folder, this will ensure that the path for the tracks in your library are update rather than the tracks being re-imported as new files.