Nucleus InternalStorage folder gone crazy!

Last night I switched on my laptop that I hadn’t used for some weeks, to download an album from Bandcamp using a download code from an LP I’d bought. This worked fine and I Copy and Pasted it into the Music folder within the Nucleus InternalStrorage folder over the network.

When I switched on my iPad to view the Overview, I expected to see the new album. Instead, Roon had started importing hundreds of new albums, which turned out to be multiple duplicates of albums already in my Roon library. After over 1000 duplicate albums had been imported I decided to disable the Nucleus from seeing the InternalStorage folder. After this action, only my 458 TIDAL albums were visible.

When I opened the Nucleus network location on my laptop, I found that the InternalStorage folder which should’ve just contained my SACD rips folder and Music folder, also contained another InternalStorage folder that wasn’t there before. Clicking on that folder produced another InternalStorage folder, and another and another to infinity etc. as shown below:


We then went into:

…and tried to delete the InternalStorage within the InternalStorage folder. Before deleting, the laptop analysed the size of this directory and it was 33TB (not a typo). Even though my SSD in the Nucleus is only 2TB!

Before we deleted the InternalStorage within InternalStrorage we backed up the SACD and Music folders onto an external 2TB HDD. After the overnight deletion process was completed we discovered that the two music folders had also been deleted, even though they were not selected for deletion at the start.

Now the InternalStorage folder contains no music at all, however, it still contains an endless pathway of extra InternalStorage folders which cannot be deleted, even after changing the name of the mother folder.

Since this InternalStorage folder weighs 0.0KB, we decided to ignore it and tried to transfer all the music files directly from the HDD to a newly created folder in the Nucleus’ Storage folder within the almost empty 2TB SSD. This was unsuccessful as a message came up saying there was not enough space in it for the files, even though the Nucleus web browser showed 1848GB/100% space free.

We switched the Nucleus on and off, and right away an Update was required to Roon V1.60, and showed the current version as 1.0, even though I know the Nucleus was previously updated to 1.6.

Basically, the SSD is empty but unusable, the InternalStorage folder is impossible to delete and the Nucleus has reverted to 1.0. But my TIDAL albums are still recognised…

Any suggestions?

This has happened to me (twice) on my ROCK NUC. see:

I did a reinstall / reformat of the internal drive / restore of the music files to get back up and running. Fortunately, this is a very rare bug. Unfortunately, because it’s very rare, Roon Labs are going to have the devil of a job to track it down.

Hi Geoff, hope you are well.

Yes, it’s very odd that this has happened. I see you had the same issue.

I’m not entirely sure what you mean as I’m unsure about you’re use of several forward slashes (/) in the post you made. Do I need to press some or all of the blue buttons in the browser screen as listed below?

I currently have the Nucleus web browser on my laptop screen and it says: (blue buttons in brackets)

Operating System: Version 1.0 (Reintall)

Roon Server Software: OK Version 1.6 (build 416) stable (Restart)

Internal Music Storage: OK 2000GB, SanDisk SDSSDH32
100% of 1848GB available (Format)

Roon Labs Software: Version 1.0 (build 11) stable

Roon Database & Settings: OK 95% of 55GB (Reset)

What I was meaning to say was that I did the following:

  1. Reinstalled the Operating System (using the Reinstall blue button)
  2. Stopped the Roon Server (click the down arrow on the Restart blue button for the Roon Server Software).
  3. Reformatted the internal HDD holding my music files (using the Format blue button for the Internal Music Storage).
  4. Restored all my music files over the network to the now-empty internal HDD from a backup of my music files and folders)
  5. Restarted the Roon Server Software using the blue button.
  6. Started breathing again. :wink:

I should say that reinstalling the Operating System should not wipe out the pre-existing Roon database and your settings. see the KB article.

If I do this, can I leave my USB pen drive Roon Database backup in the Nucleus?

Shouldn’t do any harm to leave it in place. But personally, on the belt and braces principle, I would probably remove it until all the steps had been done.

Ok that’s all worked and we’re copying over the music to the InternalStorage SSD again. Thank you. Only 6 hours to wait! :sweat_smile:

Just an additional query…

Should the Operating System version be 1.0 or 1.6? Currently it says it’s v1.0 (build 175) stable.

The OS is 1.0 build 175; it’s the Roon software that’s version 1.6, build 416… Two different pieces of software.

Hi @Woo,

Thanks for reaching out to us here. As @Geoff_Coupe mentioned, we have seen this behavior before but very rarely in the past. I am glad that you have been able to resolve the behavior with Geoff’s steps (thank you for providing that Geoff). I will go ahead and mark this thread as [solved] but if this behavior occurs again do let us know.


Hi there, Just returned home after a day out and have been trying to get things working.

We finished transferring the music files to the Nucleus SSD InternalStorage, so went into Settings and Enabled a new pathway for the albums on the SSD. This only managed to import about 120 albums instead of the full 800+. So we disabled this pathway and enabled the Nucleus InternalStorage folder again, which should’ve worked. Straight away thousand of albums appeared again including multiple duplicates. Upon closer inspection, the Nucleus InternalStorage pathway still shows multiple layers of InternalStorage folders, when viewed from my iPad screen Roon remote.

We disabled this folder again and rebooted the Nucleus. We then enabled the new pathway again and after approx 20 albums imported, the Core lost connection and we haven’t been able to access it since.

Not even via the web interface?

We now have access after another reboot.

We now seem to have all my albums back visible on Roon. However, the file pathway for all albums seems to be a different one from the one we’ve told Roon to look in. It says this next to each album:

/roon/sys/storage/smbmounts/RoonStorage_595f4cfb8b63cdac399d9d7b16572d897da1d015/Storage/InternalStorage/SACD rips/

But the pathway we asked Roon to look for albums in is:

\NUCLEUS\Data > Storage > InternalStorage

(The original Nucleus Internal Storage folder is Disabled as it contains multiple InternalStorage folders which initiate the problem again if Enabled)

Hi @Woo,

I would try using the original InternalStorage location. If you are using \NUCLEUS\Data > Storage > InternalStorage, you are essentially telling the Nucleus to reach out to the network, and add it’s own storage location again via the network, which can trigger some strange behavior due to having it mount it’s own InternalStorage path.

Can you perform a Backup of your current database and re-enable the original InternalStorage location? If the issue is still occurring I would like to know and can request QA to review this case.

Yep, I can do a Backup. My current Backup is fine though, why do it again?

I suspect Enabling the original InternalStorage will just cause havoc again, like it did an hour or so ago.

I’ll do a backup as you suggest though and Enable the original pathway again.

Done the backup and re-enabled the Nucleus Internal Storage folder. All seems back to normal now!

Thanks guys, so helpful as ever :100:

1 Like

Hi @Woo,

Glad to hear that the issue is resolved! If you experience any other issues in the future do feel free to reach out to us again. Thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.