Nucleus+ issues as core - solved when switched core

Hi @Rodrigo_Salgado,

Sorry to hear that you decided not to pursue further troubleshooting at this time. I realize that changing devices’s connection around is a bit inconvenient, but it is the best way to troubleshoot this issue (by using process of elimination).

I will go ahead and leave this thread open for you, so if you are so interested in the future, we can pick this back up again. Just let me know when/if that time comes. Hope you stay safe and have a good weekend Rodrigo.

1 Like

Dear Noris,

Me again, back with some news!

  • I switched the Orbi router from “AP”- to “router”-mode. This solved almost all my problems with the Nucleus. Roon performed as back in the day, and consultation of the Tidal and Qobuz tabs was flawless. On rare occasions, I still got the weird network errors, but overall things had significantly improved.
  • However, with the Orbi now acting as a router my television decoder defaulted on many functionalities, as it requires a connection with the ISP network, and didn’t like the new Orbi network and its IP-handling. So I solved one problem and created another.
  • Yesterday, I connected my router not to an Orbi satellite or a direct connection to a Devolo powerline on the same Orbi network, but directly to the Orbi router itself.
  • I waited 48 hours to report, given earlier but premature successes with other interventions. Now I can tell you that everything works fine and continues to do so. Let’s hope that this can hold, but the total lack of any errors in the past two days is certainly better than anything I’ve had before.

Conclusion and advice to Orbi owners: connect your Nucleus directly to the router Orbi.

All the best,


1 Like

Hi @Rodrigo_Salgado,

Glad to hear you decided to give troubleshooting another try and thanks for the update here, happy to hear that putting the Orbi into router mode resolved the issues!

If you have further issues with Roon, do let us know and we can take another look!