Nucleus keeps disappearing or needing DB refresh

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

Cablecom Router, Netgear Orbi Mesh

Connected Audio Devices

Windows laptop, ipads, Naim Mu-Sos, DCS Bartock, Hugo2Go

Number of Tracks in Library


Description of Issue

For 3 days roon has been unstable or unusable. Multiple db refresh requests, nucleus unavailable or offline notices. I have refreshed a couple of times and hard rebooted the nucleus a few times. I have had a few hours of usability over roon and ARC but otherwise n othing. Completely down for over 24 hours now.
Don’t know what else i can do.

1 Like

Anyone able to help me troubleshoot this? Roon entirely unavailable for almost a week.
I’ve tried everything i can think of.

Hello @john_taylor1
sorry to hear about your issues.
Can you please try connecting the Nucleus to a TV or Monitor via an HDMI cable and checking the on-screen diagnostics. Ideally you’d have ethernet connected during this test so that you could see the Nucleus pulling an IP address.
Hopefully, you will see on the screen an info like this:

Manufacturer: Roon Labs
Model: Nucleus
OS: RoonOS xxx (build xxx) stable
Hostname: Nucleus
Searching for network address…

If this persists, please check your network connection

If so, it means that there are no hardware issues and your Nucleus is functioning correctly.

just use roon 1.8,i have the same .

RoonOS 1.0 (build 254) production
I don’t have the „searching for network“ message.
After Hostnamen Nucleus, I get a message about accessing via Roon remotes and then gives me a web OS address
When going to that i.p. address, I get the following:

I have tried restarting the server, rebooting and using the power switch to hard reboot.
Roon is still unusable. It either hangs upon opening, or it asks for login details like it is my first time but then recognizes none of my music or endpoints, or it tells me it needs a DB backup

Hi @john_taylor1
Can you please try the ‘Reinstall’ button to update the OS, it can’t do any harm.
My own machine:

And check your remotes for the latest version, see here:

I have reinstalled OS a couple of times. JUst now it has allowed me to log into roon but there are no recognised albums, despite the paths to my two hard drives being the same. Also there are no available endpoints, despite all 6 of them being online on the correct network.
Remote is on 2.0 build 1219

I’m sorry to hear that, john_taylor1.
Paging @support for you.

Ah, I thought you were support. Thanks for your help.
@support I have had no Roon for a couple of weeks now. Could I please get some help?

Hey @john_taylor1,

Thanks for taking the time to write in, it’s great to see you on community again! Although, I wish it were under better circumstances.

I enabled diagnostics on your Nucleus, and found fsck errors which can occur if the NVME SSD installed in the device is failing. With that, I also found additional critical errors like the below:

ritical: scx: LevelDb.Exception: Corruption: missing start of fragmented record(2)

As a next step, I will send you a PM with more information on getting an RMA started to send in the device for repair. Please keep your eye out for a message from me. :+1:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.