Nucleus manual reset?

hello, i have a nucleus that is powered on but it does not show up anywhere. The ethernet lights are solid not blinking as if to show data transmission. I tried connecting directly to router and doing a lan scan to find it and it doesn’t show up. also tried finding it through my router interface and nothing. I connected with hdmi on both ports to a monitor to get an on screen menu of sorts and nothing. I’ve tried swapping ethernet and hdmi cables plugging and unplugging from the wall. holding the power button…etc

Just wondering if there is a reset of some kind i can perform without access to any of the nucleus interface. like some sort of hard reset with the power button or someting?

Thank you

@retail_magnolia, sorry to hear about your Nucleus issues. A fellow user here, but is this a recent problem in that your Nucleus was working and now does not, or is this a brand new Nucleus you are attempting to set up in your network?

Where did you purchase the Nucleus, from a dealer or directly from Roon?

thanks yes its recent. it was ours already. so not new. i believe directly from roon

If it was purchased within the past 24 months then it is under warranty. I will tag @support for assistance as it appears you may have a hardware failure since you cannot see anything when connected directly via HDMI to a monitor.

Hi @retail_magnolia,

I have sent you a message to resolve this.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.