Nucleus Migration Issues

Yesterday I switched music servers from a MacBook Pro to Nucleus running Roon 1.7 build 667.

The Nucleus and a NAS drive containing 21,956 tracks are Ethernet cabled to a Google mesh router. The iPad used as the controller is connected to the same network via WiFi.

A McIntosh MA6700 is connected to Nucleus via USB cable.

The migration was largely but not totally successful. It took many hours as each step ran for a long time. Nucleus scanned and identified 21,956 tracks. I can see and play them when I search by artist, album, or track name. Unfortunately I cannot play tracks from within a playlist. The NAS-resident tracks are listed as ‘unavailable.’ I can see and play Tidal tracks when I search by artist, album, track name, or within a playlist. Yay!

Before, playlists showed up whenever I logged into Roon. Now, I see them only when I slide the ‘shared playlists’ selector to the right which I have to do every time I start up Roon. Counts are not visible anywhere.

How do I play tracks from my NAS from within playlists? How do I once again see counts?

Once this is accomplished I would like to copy the tracks from the NAS to the SSD drive I ordered within Nucleus.

did you restore from a backup or start fresh?

what were the steps that you used?

Just prior to migration, I made a Roon backup onto the NAS. Using the laptop that is now my former music server, I connected to Nucleus and restored using that backup file. That backup worked at least partially — I can see my playlists but as explained, something isn’t right. Once restoration finshed I connected via iPad and here I am!

Further observation: many albums are “new” in Roon now even though I have listened to them many times on my old music server, before nucleus. Tracks in these albums have no count.

A minority of albums are not new. On those I do see my counts.

On both “new” and not new albums certain tracks are not associated with their playlists even though they should be.

Hi @Jeffrey_Feuer1,

Did the location of your media change at all? Did you make any changes to Settings > Storage?

Can you share a screenshot of Settings > Storage?


Dylan: The location of my music did not change: its on the same NAS attached the same way on the same network today as it was prior to installing Nucleus.

The scan of the NAS and restoration of my Roon backup file occurred simultaneously…could that explain why some albums are new without counts while other albums are not new and have counts?

Yes. They should be done in steps.

Thanks. What I might do is reset the Nucleus to its out of the box condition, then perform the restore and once that completes connect to NAS. I hope that works. The unit produces good sound but I also want my playlists to work!

Hi @Jeffrey_Feuer1,

Can you elaborate on this? Did you add the NAS to the Nucleus and then restore a backup? I’d recommend restoring a backup from prior to this migration and let us know if there is any change. Thanks!

Trial and Error is a powerful problem solving tool that helped me over come whatever installation obstacles I initially had. Last night I reset Nucleus to factory settings and started over with lots of failure at first. Four consecutive restore efforts failed; two scans of the NAS failed; I could not even add an audio device. Then I rebooted Nucleus and things turned around. The next restore worked; the ext NAS scan worked; and I could add an audio device. By morning I saw my playlists, playcounts, and 97% of my music. I added an audio device and heard a track play before I had to head off to work.

I’m glad the migration ended well but it took way too long. Customer support is not Roon’s strong point. Hopefully I’ll have lots of good listening ahead.

I’m glad to hear that things are working for you now, @Jeffrey_Feuer1. Please feel free to reach out if we can ever be of assistance in the future!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.