Nucleus+ (new out of the box) cannot add network share from Synology DS213+ (SOLVED)

Setup :
Nucleus+ and Synology DS213+ (DSM 6.2-23739 Update 2) are connected to a small 5 port Cisco Switch.

Synology name = Diskstation, Shared Folder = Music Vault : SMB is enabled and the folder is currently used by a WEISS MAN301 (CIFS)
The Diskstation has a fixed IP address

I tried all syntaxes as mentioned on the troubleshooting page.

smb:// Vault
\\Music Vault (apparently the post doesn’t show the double backslash, but you should read it as such)
smb://Diskstation/Music Vault
\Diskstation\Music Vault

When using the user login and pw specified in DSM for the shared folder I get the “Invalid network path specified” pop up everytime.

The thing is, DSM does not allow passwords without special symbols and it is documented that that could give problems.

When trying all above combinations without password, only the ones with the Music Vault give the “Could not connect to share:Unauthorized” pop up.

Thank you for any assistance

Kind Regards


This is not the case necessarily. There is an option to enforce this type of password, but you can turn it off in the settings in DSM 6.

Thank you Anthony.

I found the settings and switched it off, so now I’m using a pw without special symbols.

Unfortunately I still get the “Invalid network path specified” message with all syntaxes.

Kind Regards


Helllo @JemHadar,

Thanks for contacting support, I’d be happy to take a look over this issue with you. The correct file-path should be the first one from your list: smb:// Vault (assuming that the IP address of the Synology hasn’t changed) or \\Diskstation\Music Vault. You mentioned that only one of them listed a different error “Could not connect to share: Unauthorized”, I believe that was the correct file path.

Are you able to connect to the Diskstation via another computer with an SMB connection? You can try connecting from a Mac OS by using the Connect to Server app and attempt to place the same credentials as you would in Roon, it should look something like this (with the IP address of your Diskstation instead of the listed one):

If you are using Windows, you can attempt to connect to it from Windows Explorer by placing the IP Address and share information in the header like so:

You also mention that the Nucleus is new, out of the box, so please confirm that you have updated the Nucleus firmware as per this page’s instructions:

Please let me know if you are able to connect from another computer to that share and which method you use.


Hello Noris, thank you for your swift response.

The nucleus updated with first login, but per your instructions I reinstalled everything :
Operating System = Version 1.0 (build 158) stable
Roon Server Software = Version 1.5 (build 339) stable

I can connect with the network share through windows using the credentials I setup on the NAS for the Nucleus+

…and now you can take a big big stick and knock me over the head with it… by connecting through windows I noticed it should be Vault Music and not Music Vault. I was just blind to it during setup.

So the message of the day : check your folder names

Noris, thank You for showing me the light :slight_smile:
and Kind Regards

BTW…this marvel is fast, incredibly fast.


1 Like

Hello @JemHadar,

Glad we were able to get to the bottom of the issue and that it was a simple fix :slight_smile: . Thanks again for contacting support and wish you a pleasant listening experience!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.