Nucleus+ No Longer Accessible

Description of Issue

Device has connected flawlessly for over a year and now cannot connect at all. I have tried rebooting Xfinity modem, new cables, rebooting Nucleus+, etc. It is clear the device is powering up and the ethernet port shows activity. I do not think it is a connectivity issue; I think it is the device itself. I used to be able to access the device via IP address and now no longer can. The device’s MAC is also no longer visible on my network. I am out of ideas. The only conclusion I come to is that the Nucleus+ device is no longer working properly.

What are my next steps to get my much-loved device back up and running? I have tried all recommended items previously provided by support.

Thank you.


Hi @Jamie_Munson,

Just a heads-up that not completing the support header questions may hinder Roon’s support team when they follow up on this. Though in this case it’s really your networking topology that’s important.

However, in the meantime I would suggest connecting a HDMI monitor or TV to the Nucleus and report back on what is displayed.

Posting an image of that screen would be very helpful to aid further diagnosis.

Thank you, Carl. When connecting the device, via HDMI, to a monitor, nothing displays at all.

1 Like

Blank screen does suggest unfortunately the device is dead :frowning:

I’ve just seen this …

Did you get a message from @ben?

I’ve just tagged him here as well so he will be notified of this new topic.

Good luck with getting this resolved.

1 Like

I received the device in July of 2021. Does this mean I am SOL 13 months in?

Thanks for the nudge, team! @Jamie_Munson I’ll follow up via PM to get an RMA started for your nucleus. Please keep an eye out for a message from me with next steps :+1: