Nucleus no longer works

Roon Core Machine

Roon Nucleus with 2TB hard drive, purchased June 2021 direct from Roon

Networking Gear & Setup Details

Nucleus is connected directly via ethernet to Asus RT-AC3100 router

Connected Audio Devices

PS Audio Directstream DSD, KEF LS50 wireless, Pro-Ject stream box

Number of Tracks in Library

Not sure and cannot check but nowhere near the max for a nucleus

Description of Issue

Roon app cannot connect to the Nucleus. Via the web interface, it says Operating System OK, Internal Music Storage OK, but Database & Settings “not ready.” If I reset the database & settings, it says that it completes successfully very quickly (<1 minute), but continues to say “not ready” and if I try to “Save,” it will say “error saving settings: UnexpectedError”

Can you connect a monitor to it via HDMI cable and see what the screen says on boot up of the Nucleus.
Just as a bit more useful information.

Although I must admit it does not sound healthy unfortunately :roll_eyes:

Once it boots, it says RoonOS 1.0 (build 227) stable
And then says it can be accessed by opening any Roon remote, etc. and gives me an address for direct access.
Roon apps will find the Nucleus if I search for Roon OS devices on the network, but it will not allow me to connect it as a core any more. The Nucleus worked just fine for 7 or so months, haven’t changed anything about it or my network, it just won’t connect as a core.

Well that’s a little more hopeful.
Does not sound terminal ATM.

Had anything changed on your network?

As I said, no, nothing has changed.

It sounds like your DB has become corrupted somehow.

Not sure if we will get any official support to assist over the weekend.

Maybe other members may have some worthy suggestions.

Thanks. Below are some shots of what I’m seeing if that is useful to anyone.

I have never used a nucleus so not sure if this would be wise idea.

I wonder if reinstall of Roon OS would help here.

Tried but cannot. It just says it’s installing and that it will take a while, but it never completes. Just spins and spins.

If you try it again a second time immediately, does it work? I have seen that error occur the first time during a reset and then once tried immediately again it finishes.

1 Like

Assuming you have a database backup you could venture down the RESET database option and restore from a backup…otherwise its sounding like yet another SSD failure.

1 Like

No. Same result if I do it again immediately.

Hi @RoonyMcRooner ,

Are you by any chance able to manually reset the Roon database by using these instructions?

  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Core” and connect to the new database

If this procedure doesn’t work, we will need to RMA the unit.

Just replying to note that I followed up with Roon and they RMA’d my unit and replaced the hard drive. It’s working fine now.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.