Nucleus - No update software


We have a Nucleus Plus that doesn’t want to update the software.
Each time it said : “an error occurred during the update check”.

So we can’t connect the unit.
I tried to reinstall the operating system without success.

Any idea about that problem ?

Thanks a lot.

Have a great day.

@SteveSilberman @support


The Nucleus + seems to be connected to the internet. It has an IP adress and the DNS sets to
When I launch roon, it says that the N+ needs to be updated. But when I click ‘connect’ the N+ try to update without success and the same message appears : “an error occurred during the update check”.

I do not believe is a valid Google DNS

Try or is an alternative if you don’t like google :stuck_out_tongue:


Many thanks !
It works now…
I don’t know why the DNS was set to !!!??
And yes, I should change it to the real Google DNS !

So, everything is ok now and thanks for your help !

Have a great day.

Best Regards,

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.