Nucleus not outputting to dac after latest update [Solved - DAC USB Board Replaced]

Roon Core Machine

Nucleus + Version 1.0 Build 227 (Roon Software 1.8 Build 882)

Networking Gear & Setup Details

Eero Mesh Network. Nucleus is connected via ethernet to the station.

Connected Audio Devices

Schiit Gungnir DAC connected to Nucleus via USB.
Various Sonos units are connected via wifi network.

Number of Tracks in Library

Description of Issue

After the latest update, the Nucleus does not output to the Schiit Gungnir DAC via USB. The remotes on my iPad, iPhone, and Macbook all recognize that the DAC is a connected device and display that, when I press play, playback is happening but there is no sound from the DAC to my amp.

I connected my Macbook directly to the DAC via USB (disconnected the Nucleus) to make sure it was not the DAC. No problem with playback from local files on Macbook and no problem when using the Macbook as the Roon Remote when the Macbook is directly connected to the DAC via USB. So, there is no problem with the USB input on the DAC or my amp.

I can play via wifi to the various Sonos units connected to the wifi network.

I rebooted the Nucleus and restarted the Roon Server Software to no avail.

It seems like the USB output on the Nucleus is failing. But, all my Roon remotes recognize that the DAC is connected via USB and it “thinks” playback to being delivered when I play via all remotes. Just no sound.

Have you disconnected the USB cable to the schiit.
Then power down the Schiit.
Reconnect USB cable.
Restart the Schiit.

It might help re-establish the " handshake" between it and the Nucleus.

I assume you have checked the settings:audio for the USB output from the nucleus that all looks good?

1 Like

Yes, I tried that to no avail. I think I’ve narrowed it down to the nucleus as being the problem because when I bypass the nucleus altogether and just use my MacBook connected via USB to the DAC everything is working fine. I can play files remotely on the MacBook and I can use the MacBook as a room remote with no problem when it’s connected directly to the DAC. When I reconnect the DAC to the nucleus, the original problem persists. It recognizes that it’s connected to the DAC but no sound to the amp.

I’ve had the usb port on Schitt gear go bad. Try testing the dad with different software.

Thanks. I tested the USB port on the Schitt with my MacBook Pro and it plays local files on the computer no problem. So I think the DAC is OK. I think the issue is the output from the Nucleus +.

When you suggest different software, what do you mean?

When you plugged it into the Mac, I assumed you might use Roon. If that had failed, the n xt step would have been to use a different app on the Mac.

Got it makes sense. When I plugged in the MacBook, I used Roon and I also used iTunes. The DAC worked in both cases when directly connected to the MacBook.

1 Like

Yes it seems to point to a issue with the USB hardware or driver.

I posted a thorough and detailed support topic over 48 hours ago and have received zero response from anyone at Roon support.

I am frustrated and would expect a reply at this point.

I was told on friday when I had a problem they don’t work weekends so don’t expect a reply until Monday at the earliest

1 Like

Hi @Steven_Mercer

Thank you for reaching out to us with your question. We apologize for the delay in responding. I had hoped to get back to you sooner and appreciate your patience.

I am very sorry to hear that you were having issues with playback to your Schitt Gungnir DAC. Since there’s been a delay in getting back to you I wanted to inquire whether you were able to get everything up and running again?

If not is the Schiit the only device that is exhibiting problems?

If you connect the Gungnir to the alternate USB out on the Nucleus does it playback successfully?

Have you updated your Roon Core and remotes to the latest version of Roon?

We’ll be watching for your reply and get back to you as quickly as we can.

Jamie – thank you for your response.

Unfortunately, the issue has not been resolved.

The Schitt is the only device that’s exhibiting this problem. I have several Sonos speakers connected via Wi-Fi which are all functioning properly.

I have switched the USB out on the Nucleus to the alternate, rebooting the DAC each time before attempting to playback. Still no change to the issue.

The Roon core is updated as well as all of the remotes. The Roon Server Software is version 1.8, build 884. I believe this is the latest version?

I was going to bring my Nucleus to the dealer I purchased it from too quickly to plug into any of their DACs just to test if indeed the issue lies with the Nucleus. I have not had time to do this yet. However, I’ve disconnected the Nucleus from the DAC, and plugged my MacBook Pro via USB into the DAC and have no problem playing music through to the amplifier either using the Roon remote on the MacBook Pro or playing files locally, independent of Roon, from the MacBook Pro when connected directly via USB to the DAC.

Hi @Steven_Mercer,

Thank you for these additional details. I’m sorry to hear that your issue persists but relieved to hear that you do get audio out of the Gungnir when connected to a Roon Remote. This is helpful to know.

A few questions, some of which may be rather obvious - please excuse my asking them.

Is the input on the Schiit itself set to USB when connected to the Nucleus?

Have you tried using a different USB cable?

Do you have another audio endpoint you can connect to the Nucleus via USB, do you get sound out of that device?

Can you please upload a screenshot of your Device setup for the Schitt including volume and advanced setup settings please?

I’ll be watching for your reply and get back to you as quickly as I can.

Jamie, Here are my responses to your questions.

Yes, I double-checked more than once that the input on the DAC is set to USB when connected to the nucleus.

Yes, I have tried a different USB cable.

No, I don’t have another endpoint but I plan on taking my nucleus down the street to the dealer from whom I purchased to see if I can hook up one of their endpoints just to double-check or further diagnose what’s going on.

Here is a screenshot of the device set up for the DAC. Hopefully I captured everything you need?

Hey @Steven_Mercer, how did it go at the dealer? If you’re still having trouble, could you also provide a screenshot of Settings > Audio?

I was able to enable diagnostics on your Nucleus and noticed that the USB & HDMI outputs might have the same Zone name, and that your recent playback attempts were to the HDMI output (hence the lack of audio).

This might be as simple as renaming the zones in Settings > Audio, and then selecting the correct one. Let me know!


Have not been able to go to the dealer yet to test another endpoint. Might do so today.

Attached is a screenshot of Settings>Audio.

I am not sure I understand your suggestion that the USB and HDMI outputs on the Nucleus have the same zone name. I do not see a setting to change the name of the output on the Nucleus. I do not see a way to determine if the Nucleus is outputting to the USB or HDMI. I NEVER used the HDMI, only plug and played from the USB output on the Nucleus so this is not something I am familiar with.

I only have one device connected to the Nucleus, the DAC via USB. Which has always been functioning properly. The other zones are just wifi Sonos devices, which are working. The only zone not working is the DAC, connected directly to the Nucleus.

The Nucleus manual says, “Nucleus will discover devices connected via USB, HMDI, and ethernet at any time.” I do not have anything connected to the HDMI so why would the Nucleus try to output to this rather than the USB and how can I control this?

When you click on the gear wheel for your nucleus and then device setup what does it say for audio?
Something like USB 2.0 or?

Sorry I do not see a gear wheel for the Nucleus.

In your audio settings, the one that’ says connected to core named Gumby.
What is that, the DAC?
Maybe I’m missing something but I don’t see the nucleus in your audio settings?

I’m never used a nucleus but I would have expected it to show as an audio device?
My actual Core shows up as two audio devices.

Yes, Gumby is the DAC. The Nucleus has never been displayed as an audio device. That is interesting that your core shows up (twice) as an audio device. I never used a core other than the Nucleus so I thought any core does not display as a device, just endpoints would display as devices. Always learning!