Nucleus not showing up last few weeks

Roon Core Machine

Roon nucelus connected via ethernet. Roon end points connected via ethernet, including ARIES g1.

Networking Gear & Setup Details

Asus mesh network

Connected Audio Devices

ARIES g1 via ethernet. Stream from my iPhone

Number of Tracks in Library

Maybe 2-3k tracks

Description of Issue

Roon nucelus suddenly stopped showing up. Cannot be detected. I tried ‘configure roon devices’ still nothing. Nucleus is powered on. Can see green light in lan cable. Tried restarting everything several times. Can’t find nucleus in router app when I see list of connected devices

Can you connect a TV or monitor via the HDMI connector and tell us what messages you see on the screen or post a photo of the screen?

Thank you. I tried this, but it just says no signal. Nothing i showing up.
I know Nucleus is switched on as I can see the green light below lan cable. When i press the power button once, the green light is gone, then when i press again, the green light is back. So at least i know nucleus is switching on and off. But it is not sending anything to the TV/monitor, so not sure what’s going on.

Then a member of the Support team will respond here with the next steps once they are back in the office. Meanwhile, two questions that will give them some information:

  • Is the Nucleus still within the two-year warranty period?
  • Did you purchase the Nucleus from a dealer or direct from Roon Labs?


I bought it from a dealer. Should be under warranty since under 2 yrs, but I will check in the receipt when back home in 2 days

Hey @Shekhar_Chauhan,

Ben with the support team here, I’m sorry to hear you’ve hit some potential hardware issues with your Nucleus! @Geoff_Coupe is correct in that getting in touch with your dealer directly is the right next step, as they should be able to help get the device in for repair.

I’ll be on standby just in case you have any additional questions! :+1: