Nucleus not updating

I just got and installed a Roon Nucleus. When I connected to it using Roon remote on my iPad, I immediately got the following: Software Update needed… Checking for an update… After about 10 minutes get ‘retry’ in red. This happened multiple times. Upon recommendation from my dealer, I downloaded the Roon remote to my iPhone which is newer model (12 Pro) than my iPad. I connected it to the Nucleus. Got same result except the update attempt never stopping after even several hours. ‘Wheel’ just keeps on spinning.

I am completely new to the Roon Nucleus and only slightly familiar with Roon in general. Soon please forgive my ignorance.


Hi, @Theodore, sorry to hear about your troubles. Have you tried rebooting Nucleus device itself via the web UI? Here’s an instruction how to open web interface for Nucleus.



Hi Ivan, I am having the same exact problem. Here are all of the things I have done to trouble shoot:

Cycled the power (hard switch)
Connected to the web ui and rebooted.
Cycled the power (web ui)
Reinstalled the operating system (web ui)
Changed location from my media center Eero to the basement Eero at the head end

It seems the device may be having issues connecting back to the Roon “mothership” to check for and grab the firmware update.

@Ivan, Thanks for the reply. Yes, I did use the Nucleus Web Administration Interface to both reinstall the Operating System and to restart the Roon server software. But get the same results. Specifically, with Roon remote app on iPad get Nucleus update required; connect; get ‘checking for update’; then after few minutes get ‘retry now’. When tried the same using Roon remote app on iPhone get the same except the ‘circle’ just keeps on spinning while ‘checking for update’. I let it run for as long as several hours.

Hey @Theodore and @Jordan_Kurzweil,

We’re grateful you’ve reported this. Our team has taken a closer look at this and we believe everything should work now. Would you please:

Open Roon on any remote device, connect to the Nucleus and navigate to Settings → About to update. Should that fail, please navigate to the Web UI and click reinstall.

1 Like