Nucleus plus, unable to connect - not found


I have a Nucleus plus, purchased directly from Roon. Initial set up was smooth and I transferred my music files and set up Quboz, all without an issue. Has worked seamlessly until…

About a couple of weeks ago, my Roon remotes couldn’t find the Nucleus plus for the first time. I was busy at the time and just now getting around to checking it out. I went through the steps outlined in the forum for trouble connecting. The appropriate lights are all on and the connections are intact. I powered it off the nucleus plus and back on. I also did a reset on all of the Google wifi units (4 total) and the modem. None of the power cycling made any difference.

The NP is connected to a TP Link switch with ethernet cable and that switch is connected to a Google Wifi hub also with ethernet which is also connected to the modem. The ethernet lights on the NP light up and on the other end of the cable on the switch they light up.

I’m at a loss for how to get the unit back up and connected. Any help is appreciated!

Couple of things to try.

Can you reach the Nucleus Web GUI from a web browser ?

Can you connect a monitor to the Nucleus via HDMI and see what appears on the screen when you reboot the nucleus?

1 Like

I have not been able to establish any remote connect to the Nucleus. When I click to “configure Roon OS devices…” it is unable to locate a device to connect to.

I will try to connect a monitor tomorrow afternoon and report back.


So I tried connecting one of 24 inch BenQ monitors with 2 different HDMI cables on both HDMI output A and then B of the nucleus+ and I couldn’t get a signal. The monitor just said no signal detected. I also powered down and back up the nucleus and still no signal from either HDMI.

Well that sounds fatal I’m afraid.
How old is it and where did you purchase it?
I think it’s going to need to be repaired.
Possibly SSD or motherboard?

Bought 7/2021 from Roon website

Well let’s tag @support and see how they want to proceed on this one.

Thanks for the quick replies, I guess they monitor this and will respond? I assume this is still under warranty since it’s barely 6 months old.

Bought the NP because I wanted it to just work when I wanted to play music, and it had up until recently. Frustrating to have to deal with this…

Yes they do and I flagged support so I would expect them to respond fairly soon.

Hi @Kent_Morris ,

Thank you for your patience here while this case reached our queue!

Yes, this sounds like a Nucleus hardware issue, I will send you a private message on the forum (shows up as a green notification) to request the details needed to process this RMA, thanks!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.