Nucleus requires Update, but download is Not possible

Hi, just bought a Nucleus and wanted to start with Roon App on my iPad.
Nucleus is connected via LAN to my router, system status is ok:
OS Version 1.6 build 175
Server software 1.6 build 416
Internal storage Sandisk SSD PLUS 1TB also ok, and also others.
Starting Roon App Roon Core is shown but with message that update is required (by the way: Icon shows a laptop and not the Nucleus picture of the Quick install)
When i press the connect button, he says that for (Remote) Core Nucleus 1.6 build 416 an update is ready
Pressing download and Install, I get the error message:
“There was an error checking for an update”
When pressing retry nothing happens.
I already rebooted the system, but nothing helps.
I need urgently your support to stop this “nightmare”


Open up the web admin page and hit re-install. That should download the latest OS and allow the latest server software to install. Try that.

Hi, thanks but does not work!
Reinstallation successfull, but with the same Build 175
Error message refers to Roon Server Software Version 1.6 Build 416
Restart done, but still the same issue :disappointed:

2 posts were split to a new topic: Unable to update Nucleus, error message

Hi @Uwe_Zimmermann,

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link? Thanks!

6 posts were merged into an existing topic: Unable to update Nucleus, error message

Thanks, @Uwe_Zimmermann. I’ll be meeting with the team to discuss shortly and will follow up after that.

Hi @Uwe_Zimmermann — I just wanted to update you and let you know that our senior technical team is investigating this and, as soon as they’ve provided feedback, I’ll be sure to reach out with their findings and next steps.

Thanks for your patience while we’re looking into this!

Thanks for the Update, appreciate your Support, although my frustration is high because this not what you expect when buying such a gadget…
Hurry up :stuck_out_tongue_winking_eye:

Hi @Uwe_Zimmermann,

Sorry for the delay! Things should be working now, can you try reinstalling the OS from the Web UI and confirm that this is working for you after that?


Yes, reinstall worked!!
Thanks, I am very happy now :blush::+1:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.