Nucleus + Roon Core Update Fail

My Nucleus + could not update since it was previously updated successfully to v1.7 (build 511).
The update was extremely slow and stuck in the downloading process.

I tried to reboot the Roon service or reboot Nucleus several times, but it did not help, always failed to finish the downloading. Below is one of the snapshots.

What’s wrong with my Nucleus? What should I do to fix this? Thanks in advance!

Have you tried a reinstall form the GUI…(Available at of course make sure you have a backup of your database first but this should still be inatact after a reinstall.

Yes, tried the “Operating System” reinstallation from the GUI.
Failed the same. Also tried power off and power on Nucleus, didn’t help.

Are you by any chance in china or behind a firewalled network connection?

Hey Wizardofoz,
Thanks for the quick response!
Yes, in China, but never got this problem before, and no any changes for network settings recently.

I checked my router settings. Just found the “firewall protection” is enabled.
Does it help if I turned off the IPv4 and IPv6 SPI firewall protection? See below image for current setting.
Or any other settings need to be changed to fix my problem? Thanks again!

I guess try it…maybe the country IT folks made changes that affect AWS links.

In the meantime can you try a VPN option setup on the router?

I’m sure support will be along in time to chime in with other options.

Hi @Kinlin_Chu,

Can you try rebooting the Nucleus from the Nucleus Web Administration Interface and let us know if that helps?

Also, as mentioned above, this could be a firewall issue and so using a VPN might help here as well.

Let us know if this helps!

Thanks Wizarddofoz and dylan!
Just fixed my problem by disabling the IPv4 SPI firewall protection.
Now Roon system updated to the latest version. Thanks again!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.