Nucleus+ Roon Server continuously rebooting

(Craig Palmer) #1

My Nucleus+ went a bit crazy today it seems. All roon remotes (iPad, iPhone, Mac) show a continuous loop of connecting and then being disconnected – you get the roon icon like you do when the server is rebooting – and then it continually repeats and it’s never up long enough to play music… But at any time this is happening I can go to the web interface for the Nucleus+ and system status shows all things normal. I tried restarting the Nucleus+, restarting just the roon server, and completely unplugging the Nucleus+, leaving it for about 30 minutes and then connecting it back up again but the same symptoms repeat. Need some help with this…

(Dylan Caudill) #2

Hi @Craig_Palmer,

Can you describe your networking setup?

Were there any changes to your setup (networking or otherwise) around the time this started happening?

Do you have any USB devices connected to the Nucleus? If you disconnect them is there any change?

(Craig Palmer) #4

My network setup has been in place for a couple of years now without issue and nothing has been changed recently at all. It is all Ubiquiti Unifi devices: 1G connection to the house --> Unifi XG-8 router/firewall --> Unifi XG-16 Switch --> 20G connection to a 2nd Unifi XG-16 Switch in my theater --> Fiber connection to a 10GTek Fiber to Ethernet Converter to my Nucleus+ powered by a HDPlex 200W LPS. I have had no network issues in my house. The Roon Remote issues I’m experiencing are consistent whether it is a iPad/iPhone connected via Wifi or a Mac using a wired lan connection. As previously stated I have no problems getting to the web interface of the Nucleus+ and at all times even when the Roon Remote is cycling between connected and disconnected.

I did have a USB memory stick attached to the Nucleus+ used for local backups (I also backup to Dropbox). I disconnected it and rebooted the Nucleus+ but the same symptoms persist.

(Dylan Caudill) #5

Hi @Craig_Palmer,

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

(Craig Palmer) #6

Well, in a strange twist, after the Roon server rebooted itself 1-2 times per minute overnight for almost 13 hours. I rebooted the Nucleus+ almost 2 hours ago after I removed the USB stick at your request and as I reported, the Roon Server kept rebooting and did so for another 90 minutes but then suddenly stopped rebooting. I’ve now been playing music successfully with a stable Roon Server now for almost a half an hour. Nothing that I know of changed in any of my setup.

(Dylan Caudill) #7

Hi @Craig_Palmer — Thanks for the update.

I’m glad that things seem to be working for you now. The team looked at the diagnostics report and it looks like the connection between the Nucleus and an NAD zone got into a bad state that was causing this issue to occur. If you see this behavior again, try disconnecting the NAD device and let us know if that changes anything.

(Craig Palmer) #8

Can you tell me which one? I have around 13 of them. And I just did remember that the NAD zones updated with a new release a few days ago. Wonder if that had any impact…

(Craig Palmer) #9

Well, my Nucleus+ is back at it and Roon Server is again rebooting once or twice a minute.

Can you please take another look at the logs and tell me which of my NAD devices are misbehaving? With 13 of them I need to have it narrowed down. Clearly something isn’t right here and needs to get properly diagnosed and fixed.

(Craig Palmer) #10

Follow-on info. I have tried rebooting the Nucleus+ again multiple times and that has not gotten the system to a stable state.

Then I turned off all of my NAD devices (8 CI720s (single zone each), 1 CI580 (4 zones), 1 Node 2) given you said the logs show a problem with connecting to one of them. This did also did not get the system back into a stable state. I rebooted the Nucleus+ after this and the Roon Server continues to reboot 1-2 times per minute.

Need some help @support with this please as I’m again dead in the water.

(Dylan Caudill) #11

Hi @Craig_Palmer,

I just met with the team to discuss this further. The zones that they had previously thought might be an issue were NAD CI580 + NAD CI720 + Theater. But since you powered down all of the NAD devices and this issue is still occurring, there is likely something else at play here.

Moving forward, the team is hoping that you could use the directions found here and send us over a set of logs using a shared Dropbox link. They want to compare the prior diagnostics report with the logs for the current issue.

(Craig Palmer) #12

Here’s my log files:

FYI – I tuned the NAD zones back on after seeing that having them off didn’t change anything. Assume you’ll see that in the log files.

(Craig Palmer) #13

And FYI – I’m in the process of setting up another core (with the backup from the Nucleus+) on a Mac Pro. It’s the machine I ran core on before the Nucleus+. I do have 2 lifetime licenses so I can have both systems up simultaneously and hopefully fall back to the Mac Pro if I have to if the Nucleus+ is borked.
I’ll let you know once the backup completes and I tweak the storage locations to complete the setup if this configuration (with all the same endpoints) has the same issues.

If this isn’t helpful to the process on your side let me know and I can stop.

(Dylan Caudill) #14

Hi @Craig_Palmer — Thanks, I’ve downloaded the logs and passed them along to the team. I’ll reach out ASAP when they’ve provided feedback.

(Craig Palmer) #15

2nd Roon Core up and running on a Mac Pro with the same set of endpoints. No issues so far with Roon Server rebooting all the time and it’s been running for a couple of hours…

(Craig Palmer) #16

Nucleus+ has still not recovered and Roon Server continues to reboot at 1-2 times per minute and has been doing this since yesterday morning.

And my 2nd Roon Core continues to run fine on my Mac Pro with all the same endpoints as the Nucleus+.

@support – any further update on analysis of my log files and ideas to fix the Nucleus+?

(Dylan Caudill) #17

Hi @Craig_Palmer,

I checked in with the technical team on this — They’ve let me know that they’re still currently investigating and should have some further feedback for me soon. I’ll be sure to keep you updated as soon as I learn more. Apologies for the trouble, and we appreciate your patience here.

(Craig Palmer) #18

Ok @dylan - Thanks. At least I’ve got a backup for the moment.

(Dylan Caudill) #19

Hi @Craig_Palmer,

I spoke with the team about their investigation into your report and I wanted to follow up with you.

What the team is seeing is similar to what we’ve seen in the past when there are uncommon networking issues at play that it overloading the device and causing it to crash. Your network is quite complex, and you have many networked devices on the network as well, so there are several places where things could be failing.

Starting out, the team is hoping that you can reboot all of your networking gear. After everything has been rebooted one by one is there any change?

(Craig Palmer) #20

No change. As a matter of fact I updated all switches and aps with new firmware yesterday and rebooted with no change to the roon server rebooting. My network is rock solid and there have been no issues with the nucleus+ for 1.5 years and roon core running on my Mac Pro with the same database, network setup and endpoints runs fine.

(Dylan Caudill) #21

Hi @Craig_Palmer,

Thanks for giving that a try. Next, I was hoping we could bypass some of the networking gear in place and connect the Nucleus directly to the primary router via Ethernet. When you’ve done so is there any change?