Nucleus scrolls through songs on album then says "nothing playing" [Investigating]

Roon Core Machine

New Roon Nucleus.

Networking Gear & Setup Details

TP- Link Archer AX50 router

Connected Audio Devices

New Nucleus to Benchmark DAC via USB.

Number of Tracks in Library

94,927 tracks

Description of Issue

Was using MacBook as Roon Core, running Tidal and playing songs off a 5 TB external drive into a Benchmark DAC. Songs loaded onto Nucleus, but when I try to play albums off Tidal or the hard drive, it just scrolls through the songs and then says “Nothing Playing”. I updated the operating system, rebooted a couple of times, and tried a different cable. No dice.

What model of Benchmark DAC do you have, and will it work with a Linux OS (which is what the Nucleus has)?

Could you also post screenshots of the Roon Settings you have for this device?

Its a Benchmark DAC3 HGC and it works with Linux.

Can you post a screenshot of the first screen of Device Settings for the USB connection to your Benchmark on the Nucleus? You appear to have only posted the second (Advanced settings) screen. Thanks.

Oh, and have you tried rebooting your Benchmark, rather than the Nucleus?

Not sure this is the screenshot you’re looking for. I did reboot the Benchmark, it made no difference.

No, I’m looking for the first screen of the device settings of your Benchmark device. What you’ve posted is the screenshot of all the devices known to the Roon Core (or at least the top half of the list).

I’m looking for something like this (this is the first screen of a USB-connected DAC on my system):

I notice that you have enabled a device connected to the Core and labelled this as “empty”. What is this? One of the HDMI connections?

Don’t forget the obvious. Make sure in you are still logged in to tidal.

It’s not just Tidal - also happening with local files. Issue points to a mismatch (possibly in device settings) between the Core and the DAC…


The settings seem to be OK to me, but I’m not familiar with these DACs. Let’s see what @support have to say…

Hi @David_Gillett,

I thought I might have a quick answer so I am here to chime in. Can you please try this and let me know what happens?



  1. Select the USB input.
  2. Press and hold both INPUT buttons for 3 to 10 seconds.
  3. The 4X light should flash after 3 to 10 seconds.
  4. If the 2X light flashes when selecting the USB input, go back to step 1.

This didn’t work. Neither 4X nor 2X flashed. Both lit, and the Nucleus dropped the Benchmark. I toggled between USBs and the Nucleus picked up the Benchmark again, but the scrolling/not playing problem remains. Now the Benchmark does not respond to my preamp.

Hi @David_Gillett,

This is unexpected behavior. I have the attention of a hardware expert with your case. Can you please remove the power and USB from the back of the Benchmark and let it sit for 30 seconds and try again?

Let me know and if that doesn’t work, try to play a song to it and give me a timestamp and track info. I will review logs again with the experts!


Rebooting Benchmark didn’t work. Not sure how to get you timestamp and track info.


Hi @David_Gillett,

Just duplicate the issue and reply with the time you did it and what track you played.


Hi Wes. Sorry, I don’t understand what you are asking me to do. (I am mostly ignorant and somewhat slow where tech is concerned.)

Wes is asking you to play some tracks to the Zone that is the Benchmark DAC, and just note the time, date and track titles when you do this. He will then pull the logging information from your Nucleus remotely, and using the time and date information that you have provided, go to this point in the logs and see what information about the problem has been recorded in them.

Thanks Geoff.

This happens every time I try to play an album or track, so any track logs would probably show the same thing. Here are a few tracks I tried to play this morning:

All Is Full of Love (Plaid Remix) 8:37
Fairytale (Takes 1, 2) 8:38
Just Because 8:39

1 Like

Sigh. I finally got it working, thank you. Yes, the Benchmark USB had to be reset to 2.0 and I had a little trouble doing that. Thank you for your patience.

Today I got a bill for $119.88 for a year Roon subscription. I was told the first year is free with purchase of a Nucleus. Is this something you can help me with?

Hi @David_Gillett,

Taking our conversation private.