Nucleus struggling with DSD512 since buid 571

Hi there,

My Nucleus is now struggling with DSD upsamling to DSD512 since the Build 571 release. When stepping down to DSD 256 all is fine. Could Build 571 being more resource consuming?

By the way at the same time Lumin made an update to version 13.0a. So hard to figure out what really triggered the issue.


That does not make sense because downsampling DSD512 takes more resources than playing DSD512.

Hi @Bruno_Boutantin,

Can you share a screenshot of the Signal Path when playing this type of content?


I read his post to mean that upsampling to DSD 512 is the problem, but that upsampling to DSD 256 is ok. I don’t think he meant that he’s downsampling DSD 512 to DSD 256?

1 Like

I see. I reacted to his use of the words “stepping down to DSD256” as downsampling. If I am in error, I would say that upsampling is just as memory intensive as is downsampling and he doesn’t say what his source material is.
If he is saying that upsampling DSD64 to DSD512 fails while upsampling DSD64 to DSD256 works fine but that both worked well prior to Build 571, the likely (but not certain) issue is with Roon.

This is what he is saying. He’s just not saying from where is he starting.

Please post a signal path screenshot.

Enable Parallelize Sigma Delta Modulator in DSP Engine setting.

I do upsample everything to DSD 512 but now only upsampling to DSD 256 works. With DSD 512 after between 1:45 or 2 minutes it starts failing.
See below path working well in DSD 256 cannot get it work moving back to upsampling at DSD 512.

It was on all time. So not the issue.

@Bruno_Boutantin Im not seeing any processing speed showing up but that shot is only doing DSD256…so a shot of the when the issue is happening would be with DSD512 maybe showing any differences

Is the X1 on the latest V13A or V12 firmware?

Is this an i7 Nucleus + or the i3 Nucleus

Processing speed only shows up if its under 100X but if it shows and its below ~1.4X you will get dropouts and other issues.

It’s on latest firmware 13a. It’s Nucleus i3.
But as said was working fine for months till the minute after Build 571 was installed.
DSD512 path identical. I do not know to show processing speed?

it only shows processing speed when its under 100X

If selecting DSD 512 I start to have dropout within 1:45 or 2 minutes depending of then material.

Network is all wired? no mesh/wifi between core and X1?

Every release is potentially more demanding on the Core hardware as new features are tuned and added

Network is wired even with fiber and nothing changed, It’s all running 1 giga speed.
I was even streaming as well Qobuz material upsampling everything at DSD 512.

There is one thing I have to highlight: due to the Google network most recent issue the Firmware update failed several time not being to access the server before it was self solved with acees restored.

Fiber between Cisco Switch and X1. Fiber to the house, the other stuff in Cat6a.

Just a thought…maybe see if a Cat6 connection makes any difference at the X1 side

is there any info in the Lumin app on the network connection?

Please power cycle the Cisco Switch, Nucleus and the X1.

Make sure you’re playing tracks from local music files, not from Tidal / Qobuz. Just to eliminate possibility that there is Tidal / Qobuz download speed issue, however slight it may be.

Hi Peter,
First of all, you guys at Lumin are doing an awesome job, kudos!
I went yesterday evening through the power cycle of all and resume playing from the Syno and still same situation upsampling to DSD256 all fine, moving up to DSD 512 : dropout.
As a side info: The Syno is connected to Cisco using dual Giga ports, Syno up to date and healthy.