Nucleus+ unresponsive

My Nucleus+/Roon setup was working fine until this morning. Then Roon software (Mac) kept asking me to log in to the core, but when I would log in it would tell me that I was already connected to the core (which it correctly showed as my Nucleus+) and ask me to hit the “back” button to connect. But that only brought me back to the login screen (endless repeat). I decided to try to re-boot the core, and the power light over the switch was lit, but I could not power cycle the unit by pressing and holding the power key (unresponsive, although the light stayed lit). I decided to force a re-boot by unplugging it, but now it will not power back on. Hard to believe it is an overheating issue as the case is pretty cool to the touch. Please advise. Thanks.

Fwiw, it’s NOT the power supply. Put a meter on it and got the expected 19v.

Hi @Hal_Greene,

Are you able to reach the Nucleus Web Administration Interface?

If not, can you try connecting the Nucleus to a TV or Monitor via HDMI? Do you see anything on the screen? If so, please send a picture. Thanks!

Nothing on the HDMI port (tried that) and can’t ping the unit or access via HTML.

Oddly, the unit gets quite warm when plugged in for an extended amount of time, and when I remove the base plate I see a lit LED on what appears to be the motherboard, so it’s not COMPLETELY dead. But still no power light and does not appear to be powering on or booting up in any recognizable fashion.

So this morning out of curiosity I plugged the Nucleus in and it booted up fine and seems to be working again (after sitting unplugged for a few days). So…is there still a problem? Or was it just an overheating issue?


Hi @Hal_Greene,

Has the Nucleus continued to work okay?

It’s possible that it was overheating — Is it in a well ventilated location?

Thanks, @Hal_Greene.

If you see any issues return please do let us know and we’ll enable diagnostics and take a closer look.