Nucleus update to 1.4 [Solved - Rebooted Nucleus]

New to Roon Nucleus. Says it needs to update to 1.4. When it tries to connect, the wheel just spins and does not update.

Hello @Greg_Gustafson,

You’ll want to use these instructions (<- clickable link) to update your Nucleus to the latest firmware. Nucleus is actually on 1.6 now so you should be seeing 1.6 b390 on the WebUI after performing the update.


Not sure how to navigate to the Administration Interface.

When I launch Roon it sees the Nucleus and says a software update is required.

I click “Connect” and it goes to a page that shows "Remote Core (Nucleus) - 1.4 build 310 stable checking for update.

It then has an icon spinning but nothing happens.

Thanks for letting me know that information @Greg_Gustafson.

Can I please ask you to perform these steps (in order):

  • Unplug your Router, wait 10 seconds, plug it back in
  • Power off your Nucleus, wait 10 seconds, power it back on
  • Try updating the firmware through the Remote once again
  • Let me know if that helps


Why is it that I don’t follow the advice I give my wife all the time? “Shut everything down and restart it all.”
Problem solved, thanks!

Glad to hear that a reboot solved it @Greg_Gustafson!

Also you may want to take a look at our Nucleus Documentation in case you have any questions getting started.

Hope you enjoy the Nucleus :wink:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.